Bug 1322088 - Scoped search autocomplete submits blank string
Summary: Scoped search autocomplete submits blank string
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1325784 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-29 19:01 UTC by John Mitsch
Modified: 2019-09-26 16:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13118 None None None 2016-04-22 15:08:08 UTC

Description John Mitsch 2016-03-29 19:01:16 UTC
When searching an invalid field "foo = bar" in a search box, scoped search provides the first autocomplete as a blank string. If the user hits Enter, a blank string is submitted and not the query in the search box.

To reproduce; Navigate to the search box, type "foo = bar" (without quotes) and hit enter. In the params passed to the server you will see a blank string as the search query.

 If you click the search button, then "foo = bar" is submitted in the params.

Expected results: Enter submits the query in the box if there is no autocomplete results.

Comment 1 John Mitsch 2016-03-29 19:01:18 UTC
Created from redmine issue http://projects.theforeman.org/issues/13118

Comment 3 Bryan Kearney 2016-03-29 20:01:36 UTC
Upstream bug assigned to jomitsch@redhat.com

Comment 4 Roman Plevka 2016-04-11 08:12:29 UTC
*** Bug 1325784 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2017-03-30 20:48:50 UTC
Thank you for your bug report. This bug is being tracked upstream, and will no longer be tracked in the downstream product. When the upstream issue is fixed, the next Satellite release will contain the fix. I am closing this out as deferred. If you feel this is not correct, please feel free to open with additional information. Thank you for your interest in Red Hat Satellite.

Comment 6 Bryan Kearney 2017-03-30 20:48:51 UTC
Thank you for your bug report. This bug is being tracked upstream, and will no longer be tracked in the downstream product. When the upstream issue is fixed, the next Satellite release will contain the fix. I am closing this out as deferred. If you feel this is not correct, please feel free to open with additional information. Thank you for your interest in Red Hat Satellite.


Note You need to log in before you can comment on or make changes to this bug.