Bug 132216 - unused raid metadevices are shown as active
unused raid metadevices are shown as active
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 18:06 EDT by Matthew Galgoci
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 22:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2004-09-09 18:06:32 EDT
Description of problem:

I cannot mdadm --manage --stop /dev/md10 or raidstop /dev/md10 on 
an unused but active linux software array.

Here is /proc/mdstat:
# cat /proc/mdstat
Personalities : [raid1] [raid5]
read_ahead 1024 sectors
Event: 5
md10 : active raid5 sde1[0] sdl1[7] sdk1[6] sdj1[5] sdi1[4] sdh1[3]
sdg1[2] sdf1[1]
      124430656 blocks level 5, 64k chunk, algorithm 0 [8/8] [UUUUUUUU]
       
md0 : active raid1 sdb1[1] sda1[0]
      136448 blocks [2/2] [UU]
       
md2 : active raid1 sdb2[1] sda2[0]
      2096384 blocks [2/2] [UU]
       
md1 : active raid1 sdb3[1] sda3[0]
      6650816 blocks [2/2] [UU]
       
md3 : active raid1 sdd1[1] sdc1[0]
      8883840 blocks [2/2] [UU]
       
unused devices: <none>

Here is the output of mdadm --examine --scan
# mdadm --examine --scan
ARRAY /dev/md0 level=raid1 num-devices=2
UUID=1adde9c7:e77194da:43bc5f52:76e7a23d
   devices=/dev/sdb1,/dev/sda1
ARRAY /dev/md3 level=raid1 num-devices=2
UUID=a544ff0c:ad65467c:3ad51db9:576bd4b4
   devices=/dev/sdd1,/dev/sdc1
ARRAY /dev/md10 level=raid5 num-devices=8
UUID=b24e52ec:7951c2c5:67b0240a:efb64382
  
devices=/dev/sdl1,/dev/sdk1,/dev/sdj1,/dev/sdi1,/dev/sdh1,/dev/sdg1,/dev/sdf1,/dev/sde1


Version-Release number of selected component (if applicable):

Kernel version 2.4.21-15.0.4.ELsmp

How reproducible:

All the time.

Steps to Reproduce:

Make any arbitrary raid array unused and attempt to stop the array.

For example:

Steps to Reproduce:
1. umount /boot
2. mdadm --manage --stop /dev/md0
  
Actual results:

raid array continues running because it is seen as in use.

Expected results:

raid array should stop.

Additional info:
Comment 2 Doug Ledford 2005-10-17 22:53:08 EDT
This looks like an old report that was solved long ago.  If this is still an
issue, then please reopen the report.

Note You need to log in before you can comment on or make changes to this bug.