This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 132218 - Yelp menu incomplete (scrollkeeper?)
Yelp menu incomplete (scrollkeeper?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
http://members.gtw.net/~deisenst/yelp...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 18:42 EDT by David Eisenstein
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 11:02:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Eisenstein 2004-09-09 18:42:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; de-DE; rv:1.4.1)
Gecko/20031030

Description of problem:
The problem with not getting a full menu when running "help" or "yelp" is
with the scrollkeeper program, but it affects yelp users.  One of the
scrollkeeper programs is responsible for creating a temporary file with a
list of contents -- /usr/bin/scrollkeeper-get-cl .  It uses a set of 5
temporary files, named "/tmp/scrollkeeper-tempfile.0"
"/tmp/scrollkeeper-tempfile.1" ...  "/tmp/scrollkeeper-tempfile.4",
one for
each time this program is called.

These files get cycled through.  When it's time to use a file that's owned
by another user, this program fails.

For example, lets say on a freshly-installed system, dave uses yelp twice.
Then bill gets on and uses yelp three more times.  The temporary files
used
by the scrollkeeper-get-cl program would then look like this:

-rwxr--r--    1 dave     dave        43798 Sep  7 18:28
/tmp/scrollkeeper-tempfile.0
-rwxr--r--    1 dave     dave        43798 Sep  7 18:29
/tmp/scrollkeeper-tempfile.1
-rwxr--r--    1 bill     bill        43798 Sep  7 18:30
/tmp/scrollkeeper-tempfile.2
-rwxr--r--    1 bill     bill        43798 Sep  7 18:31
/tmp/scrollkeeper-tempfile.3
-rwxr--r--    1 bill     bill        43798 Sep  7 18:33
/tmp/scrollkeeper-tempfile.4

When bill goes to use yelp yet one more time, the full menu will not
appear, because bill cannot delete and re-use the
"scrollkeeper-tempfile.0"
file.  Every time thereafter that bill goes to use yelp, it will fail to
show a full content menu, unless dave uses it twice.  User sue, tom, and
frank may was well forget being able to see a full menu.


Version-Release number of selected component (if applicable):
yelp-2.4.0-1  scrollkeeper-0.3.12-2

How reproducible:
Always

Steps to Reproduce:
(see description)    

Actual Results:  (See description and the images 
at <http://members.gtw.net/~deisenst/yelp/Yelp_bug.html>.)

Expected Results:  (See description and the images 
at <http://members.gtw.net/~deisenst/yelp/Yelp_bug.html>.)

Additional info:
Comment 1 David Eisenstein 2004-12-08 11:02:39 EST
Okay, according to gnome.org's Bugzilla, # 113151 at
    http://bugzilla.gnome.org/show_bug.cgi?id=113151

this bug was fixed with scrollkeeper-0.3.14.  This should not be a
problem with FC2 or FC3.  More about this problem is documented in
the Scrollkeeper website in their bug-tracking system, issue #
798614, at
http://sourceforge.net/tracker/index.php?func=detail&aid=798614&group_id=11543&atid=111543

I am closing this, as hopefully a FC1 user can just download the
FC2 scrollkeeper-0.3.14-2.1.src.rpm or .i386.rpm and get the problem
fixed.

    

Note You need to log in before you can comment on or make changes to this bug.