Bug 1322311 - On SSL enabled undercloud the aodh publicURL gets configured as non-https
Summary: On SSL enabled undercloud the aodh publicURL gets configured as non-https
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-30 09:30 UTC by Marius Cornea
Modified: 2016-08-11 11:29 UTC (History)
10 users (show)

Fixed In Version: instack-undercloud-4.0.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:29:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Marius Cornea 2016-03-30 09:30:33 UTC
Description of problem:
On SSL enabled undercloud the aodh publicURL gets configured as non-https 

Version-Release number of selected component (if applicable):
instack-undercloud-2.2.7-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy SSL enabled undercloud
2. openstack catalog show aodh

Actual results:
[stack@instack ~]$ openstack catalog show aodh
+-----------+--------------------------------------+
| Field     | Value                                |
+-----------+--------------------------------------+
| endpoints | regionOne                            |
|           |   publicURL: http://192.0.2.1:8042   |
|           |   internalURL: http://192.0.2.1:8042 |
|           |   adminURL: http://192.0.2.1:8042    |
|           |                                      |
| name      | aodh                                 |
| type      | alarming                             |
+-----------+--------------------------------------+

Expected results:
publicURL: https://192.0.2.1:8042

Comment 1 Daniel Becker 2016-03-30 10:44:43 UTC
Is AODH deploying by default?

Comment 2 Marius Cornea 2016-03-30 10:47:44 UTC
Yes, the deployment was default + SSL certificate with the latest puddle.

Comment 3 Mike Burns 2016-03-30 17:57:04 UTC
Moving to 9.  We're going to be dropping aodh from the undercloud in bug 1322557.  It will be re-added in OSP 9.

Comment 11 Marius Cornea 2016-07-28 09:46:23 UTC
[stack@undercloud ~]$ rpm -qa | grep instack-undercloud
instack-undercloud-4.0.0-8.el7ost.noarch

[stack@undercloud ~]$ openstack catalog show aodh
+-----------+----------------------------------------+
| Field     | Value                                  |
+-----------+----------------------------------------+
| endpoints | regionOne                              |
|           |   publicURL: https://192.168.0.2:13042 |
|           |   internalURL: http://192.168.0.1:8042 |
|           |   adminURL: http://192.168.0.1:8042    |
|           |                                        |
| name      | aodh                                   |
| type      | alarming                               |
+-----------+----------------------------------------+

Comment 13 errata-xmlrpc 2016-08-11 11:29:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.