Bug 132233 - avc denied for exe=/sbin/minilogd during boot initscripts
avc denied for exe=/sbin/minilogd during boot initscripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 22:26 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 13:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
avc denied lines from /var/log/messages during boot (693 bytes, text/plain)
2004-09-09 22:27 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2004-09-09 22:26:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
During boot to multiuser runlevel 5 with targeted permissive policy,
the minilogd program still reports three denied avc for various log
manipulations.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.11-2

How reproducible:
Always

Steps to Reproduce:
1. boot to mulituser runlevel 5 with targeted permissive selinux policy.
2.
3.
    

Actual Results:  /var/log/messages has three complaints of avc denied
for minilogd.  (A file containing the messages will be attached.)

Expected Results:  No complaints.

Additional info:

initscripts-7.78-2
Comment 1 John Reiser 2004-09-09 22:27:39 EDT
Created attachment 103667 [details]
avc denied lines from /var/log/messages during boot
Comment 2 Daniel Walsh 2004-09-10 14:44:32 EDT
The problem is the /dev/log has the wrong security context on it.

Are you running with /dev/ on tmpfs_t?

Do a restorecon /dev/log and the problem should go away.
Comment 3 Daniel Walsh 2004-09-15 11:30:33 EDT
Is this still happening with the current policy?
Comment 4 John Reiser 2004-09-15 12:59:11 EDT
selinux-policy-targeted-1.17.12-1 is now OK: these lines are no longer
produced, in neither fc3t1 nor fc3t2pre (re0908.0).  I see no
complaints when booting the latest up2date of these two systems.

Note You need to log in before you can comment on or make changes to this bug.