Bug 132235 - Enlightenment pager crashes X suddenly after running for hours
Enlightenment pager crashes X suddenly after running for hours
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-09-09 23:50 EDT by Laurentiu Badea
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:05:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Laurentiu Badea 2004-09-09 23:50:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
I mention the nvidia graphics driver because I have it on both
computers exhibiting the problem with two different cards. However,
the previous OSs installed on the computers (Red Hat 9 and Fedora Core
2) were running fine with the same nvidia driver.

The symptom is that X crashes and restarts out of the blue, during
typing or while sitting idle, with or without xscreensaver running.
The following message in /var/log/messages:

gdm_slave_xioerror_handler: Fatal X error - Restarting :0

Screensaver and power savings features are disabled.

It does not crash however if the console is left switched to a virtual
terminal (CTRL-ALT-F1).

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-6, nvidia 1.0-6111 display driver

How reproducible:

Steps to Reproduce:
1. log in to X
2. leave on or just work on it for a few hours 


Actual Results:  after few hours X crashes and login screen is
displayed again

Expected Results:  X should not have crashed.

Additional info:

dm_slave_xioerror_handler: Fatal X error - Restarting :0
Could be related to the interaction with nvidia graphics driver, or
just an xorg bug (Fedora 2 was working fine but I think it was still
Comment 1 Mike A. Harris 2004-09-10 01:33:08 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Laurentiu Badea 2004-09-10 02:30:06 EDT
Not a duplicate IMHO, I have stated clearly that Red Hat 9 (kernel
2.4) and Fedora Core 2 (kernel 2.6) have worked fine with the exact
same driver. Also I am not getting any kernel oops or other messages
(as in 73733) when that happens.

At any rate, I tested, I felt I should report, that about it.
Comment 3 Mike A. Harris 2004-09-10 02:38:59 EDT
Nvidia proprietary drivers are unsupported. Bug #73733 is our 
"we do not support proprietary drivers" bug, hence the duplicate.

Nvidia has a web based end user forum for reporting bugs/problems
with their drivers.  I think it is www.nvnews.com or somesuch.

Hope this helps.
Comment 4 Laurentiu Badea 2004-09-10 02:56:15 EDT
I assume you determined/know it's a problem with the nvidia driver 
and not xorg or the new kernel or new graphical boot. That's fine,
I guess I'll have to drag FC2 along until a fix appears.

It's somehow funny and sad because I may be wrong, but this hasty
dispatch looked just like the ISPs who refuse to provide support 
even on hardware, as soon as "Linux" is uttered.
Comment 5 Laurentiu Badea 2004-09-15 02:45:54 EDT
Narrowed the problem down to the snapshot feature of Enlightenment's
pager module. With snapshotting disabled and everything else enabled
(power saving, GL screensavers, nvidia etc), X has been stable for 
about three days.

I am not sure whose fault it is (E has been installed on FC2 four 
days before the upgrade to FC3t1 and I don't recall this problem, 
but can't be sure due to the short time involved). It's obviously
not a serious issue any longer though.

For reference these are the enlightenment-related packages installed 
on the machine:

(pager set to 100 lps, high quality snapshots)
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.