Bug 132236 - Address book errors when clicking on button
Address book errors when clicking on button
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 00:17 EDT by Mike Chambers
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 18:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2004-09-10 00:17:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040901 Firefox/0.9.3

Description of problem:
With evolution open, clicking on the "Contacts" button, it errors
instead of showing the contacts page.  It also does it when clicking
on the fields while sending an email when trying to choose the
address(s) to send to.

Version-Release number of selected component (if applicable):
evolution-1.5.94.1-1 evolution-data-server-0.0.99-1

How reproducible:
Always

Steps to Reproduce:
1.Open Evolution
2.Click on the Contacts button
3.
    

Actual Results:  Error loading addressbook.

We were unable to open this addressbook.  Please check that the path
exists and that you have permission to access it.

Expected Results:  The contact pane should open, so you can either
view your list(s) or to pick an address to send an email.

Additional info:

This error happens with you click the contacts button, or if you
create a new or try to reply or forward an email by clicking on the To
or CC buttons to choose the address.
Comment 1 Mike Chambers 2004-09-10 00:19:20 EDT
This happens on either an existing user or a newly created user.
Comment 2 Mike Chambers 2004-09-10 08:46:57 EDT
Well, after running updates last night, which is the last 2 or so days
of package updates in rawhide, the problem has gone away, and now able
to see my contacts again.

Will leave open for now for Dave to figure out why or to close if
already knows or whatever.
Comment 3 Dave Malcolm 2004-09-10 11:26:56 EDT
Some questions:
- this is with a local addressbook, isn't it? (not an LDAP one)
- are the evolution and e-d-s packages that appear to now work the
exact same versions as when the problem was occurring?
- if so, did you logout or reboot at any point?  Have you been running
a series of updates without logging out?  My hunch is that something's
stale and got refreshed by other package updates (possibly
bonobo-activation-server)
- are you (or have you ever been running) SELinux on this box?


Comment 4 Dave Malcolm 2004-09-17 14:51:31 EDT
This _might_ also be a duplicate of 132840; did you update the kernel
or the glibc package?  Whan CPU are you running on?  cat /proc/cpuinfo

Comment 5 Mike Chambers 2004-09-17 15:42:55 EDT
I don't remember if the kernel or glibc were updated after the
crashing and before the fix.

[mike@scrappy ~]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 746.875
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov
pat pse36 mmx fxsr sse
bogomips        : 1474.56

And as an FYI...I had to reinstall the OS, so I just installed via ftp
from rawhide as of yesterday, and no crashes as of yet with contacts.
Comment 6 Dave Malcolm 2004-09-22 15:23:40 EDT
Thanks for the feedback.

Have you tried it with the latest rawhide packages? evolution-2.0.0 etc...

Another question - did you ever set the environment variable
LD_ASSUME_KERNEL anywhere?

Note You need to log in before you can comment on or make changes to this bug.