Bug 1322419 - NetApp storage tab not displayed
Summary: NetApp storage tab not displayed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.5.5
Assignee: Harpreet Kataria
QA Contact: Jeff Teehan
URL:
Whiteboard: storage
Depends On: 1316733 1322426
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-30 13:20 UTC by John Prause
Modified: 2019-12-16 05:35 UTC (History)
13 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
Previously, although when NetApp storage was enabled, the storage tab was not displayed. This was because the permission store was being set to a null store that always returned true in test environment but on appliance it read from `vmdb/config/permissions.yml`. This was causing storage tab to not be visible on the appliance as it was missing from permissions.yml This patch adds the missing "Storage" main tab to permissions.yml and after a restart the storage tab is now shown.
Clone Of: 1316733
Environment:
Last Closed: 2016-07-26 15:32:10 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 1 CFME Bot 2016-04-14 21:26:39 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=037084aec7ab8490bbb1f99ba5b617b8a26e1c59

commit 037084aec7ab8490bbb1f99ba5b617b8a26e1c59
Merge: 5a2eac8 11f57d6
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Apr 14 16:52:28 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Apr 14 16:52:28 2016 -0400

    Merge branch '55z_pr_7552' into '5.5.z'
    
    Added missing "Storage" maintab to permissions yml
    
    Changes in sha 85406c43244230e9fc62385ec6f2c2f4c91cb9cf sets permission store to a null store that always returns true in test environment but on appliance it reads from `vmdb/config/permissions.yml`. This was causing Storage tab to not be visible on appliance as it was missing from permissions.yml
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1316733
    https://bugzilla.redhat.com/show_bug.cgi?id=1322419
    (cherry picked from commit bb3cb66)
    @dclarizi please review, this is clean cherry-pick from https://github.com/ManageIQ/manageiq/pull/7552
    
    See merge request !875

 config/permissions.tmpl.yml | 1 +
 1 file changed, 1 insertion(+)

Comment 2 CFME Bot 2016-04-14 21:27:05 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=11f57d6479ca92f4835ddb8ea233535c37928194

commit 11f57d6479ca92f4835ddb8ea233535c37928194
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Mar 28 16:17:16 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Mar 30 09:47:58 2016 -0400

    Added missing "Storage" maintab to permissions yml
    
    Changes in sha 85406c43244230e9fc62385ec6f2c2f4c91cb9cf sets permission store to a null store that always returns true in test environment but on appliance it reads from `vmdb/config/permissions.yml`. This was causing Storage tab to not be visible on appliance as it was missing from permissions.yml
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1316733
    https://bugzilla.redhat.com/show_bug.cgi?id=1322419
    (cherry picked from commit bb3cb66)

 config/permissions.tmpl.yml | 1 +
 1 file changed, 1 insertion(+)

Comment 3 Dave Johnson 2016-04-18 19:51:34 UTC
Last we saw, Netapp integration was completely broke, if we are displaying the tab the integration needs to work.  Per https://bugzilla.redhat.com/show_bug.cgi?id=1166841#c13 , maybe we are in good shape with this, Jason, could you confirm please.

Comment 6 Jeff Teehan 2016-05-05 19:45:08 UTC
I'm going to take this one since I did the work for 5.6.  Should be same answer as https://bugzilla.redhat.com/show_bug.cgi?id=1316733.  As soon as I have it setup I'll provide the info so that the rest of you can look if necessary.

Comment 7 Jeff Teehan 2016-05-05 21:27:45 UTC
I ran these steps and never could get the storage tab to show up.
https://access.redhat.com/documentation/en/red-hat-cloudforms/version-4.0/integration-with-netapp-storage/

Need to move it back for 5.5.4.  Dajo is going to follow up and see what John wants to do about it.

Comment 8 Harpreet Kataria 2016-05-09 15:24:22 UTC
Jeff, 

Did you follow instructions from comment #3 in https://bugzilla.redhat.com/show_bug.cgi?id=1316733

Thanks,
~Harpreet

Comment 9 Jeff Teehan 2016-05-09 20:03:46 UTC
Yes, I performed the exact same steps.  I restarted, reboot, and just plain shut it down and started it again.  I did both bugs, and the first one worked so I must have gotten it right once.

Comment 10 Harpreet Kataria 2016-05-09 21:06:49 UTC
Jeff,

Can i access your appliance?

Thanks,
~Harpreet

Comment 11 Jeff Teehan 2016-05-10 15:59:18 UTC
I had to create a new one.  https://10.16.6.64/dashboard/show  Set up the same way I always do it.

I seriously hope this is something I did.

Comment 12 Harpreet Kataria 2016-05-10 16:20:20 UTC
Jeff,

I logged in into your appliance and looked at /config/permissions.yml file, it seems that is missing the fix that was being made for this BZ i am not sure why, it has 
- :sto

on line 8, i double checked the code base and it should have been there, it appears to me that permissions.yml has been changed by someone as it's contents don't match with what is there on 5.5.4.0 code base. Do you know if by any chance line 8 - :sto got removed from that file by someone? Let me know what you find.

Thanks,
~Harpreet

Comment 13 Jeff Teehan 2016-05-10 16:41:15 UTC
I don't change anything.  And although it is possible it could have accidentally been changed by someone else, the odds of that happening on two consecutive appliances is beyond remote.

There is another 5.5.4 coming.  We should make sure it gets in that.

Thanks for looking.  At least we know what the issue is.

Comment 20 Jeff Teehan 2016-07-15 01:08:36 UTC
Took a while to go through all those steps, but it's running.  I used SDK 5.4, which is the latest I could find on the NA site last night, if that makes a difference.  I also have 4.0 I believe.

I didn't verify NetApp functionality, just the Storage UI components.

Anyway, move to verified.  We can add specific bugs if and when the arise.

Comment 22 errata-xmlrpc 2016-07-26 15:32:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.