Bug 132247 - newest samba-server frequently freezes
newest samba-server frequently freezes
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-09-10 05:10 EDT by Maciej Żenczykowski
Modified: 2014-08-31 19:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-28 13:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2004-09-10 05:10:49 EDT
Description of problem:
After latest series of updates to fedora core 2, something seems to be
wrong with the samba filesystem - pretty sure it's the samba server
which is responsible (not client or kernel).

I'm seeing frequent freezes during access - not whole system freezes,
but just the smbfs filesystem.  I'm seeing this from 3 different samba
FC2 clients.  Before updates everything worked perfectly (at over
8MB/s), now, speed remains the same, but at random moments it just
totally locks-up/freezes - only a umount/mount of the samba share
helps.  Has happened even during simple 'cat remote 2GB file' commands.

Same version on all machines.

gaia (server): 2.4.27-rc4-gaia (based on kernel.org)
zeus (client): 2.6.8-1.521smp (FC2 normal)
chronos (client): (FC2 normal)
hades (client): 2.4.18-4custom (base on RH73 kernel)

The gaia-hades combo worked before updating the samba software on
either of them, indeed I think this problem was occuring on hades
before a samba-client update as well.

Thus: I'd assume the problem is with the samba-server, or possibly the
gaia samba config, but this hasn't changed in ages, so...

Are there some extra ports that need to be opened in the latest samba

How reproducible: Always, but random - takes time.

Steps to Reproduce:
1. Just really need to use a smbfs file system for a sufficiently long
time, usually a single GB or less of transfer suffices.
Comment 1 Maciej Żenczykowski 2004-09-11 05:25:26 EDT
(the above mention of a samba-server package was an error of course -
no such package)

I'll just add that I reinstalled samba-3.0.3-5 on the samba server and
have since transferred over 80GB (using zeus as the client) without
interruptions (it'd have broken at least a dozen if not 50 times with
the newer version).

Is the newer samba using 2.6 kernel features?

Note: The easiest way to get a samba 3.0.6-2.fc2 session to freeze is
to access data on a spinned down disk - the disk spins up, but by then
the session is already frozen.
Comment 2 Johan van Baarlen 2004-09-14 14:10:47 EDT
Don't have a fix, but I can confim this to be a serious problem. 
I've got a couple of linuxboxes here, and they all show the same smb-
lockups after trying to copy a random amount of data.

Fedora Core 1, kernel, x86_64 preempt, samba 3.0.7-2.fc1
Fedora Core 2, kernel, x86 smp ht preempt, smb 3.0.7-2.fc2
Tried both as server and as client, no difference, same crap.

Gonna revert to an older version of the client-packages tomorrow, see 
if that fixes things (maybe this can pinpoint whether it's a server- 
or client-side problem).
Comment 3 Maciej Żenczykowski 2004-09-14 23:51:00 EDT
Haven't tried 3.0.7-2 as server or client yet, but the problems
appeared with 3.0.6-2 and I've verified 3.0.6-2 works as client with
3.0.3-5 being the server.  Based on your comment I'd guess the 3.0.6-2
and 3.0.7-2 server code is bad.
Comment 4 Johan van Baarlen 2004-09-15 10:38:18 EDT
Been playing with 3.0.3-5 on the server-side, 3.0.7-2 on the 
clientside. Problem is *much* less obvious, only a very occasional 
input/output error. Not perfect, but tolerable.
Vice-versa (303 client, 307 server), the problem is just as bad as 
with a full 3.0.7-setup. So I think I agree with you, it's something 
bad on the past-3.0.6 serverside of things. The really bad thing is 
that I can't use anything before 3.0.6 on our fileserver since that 
would break some windows-specific stuff.
I don't know what exactly breaks, but I'd love to get this fixed or 
worked around, it's starting to piss me off pretty badly.
Comment 5 Maciej Żenczykowski 2004-09-15 11:24:16 EDT
So you have had problems with 3.0.3-5 as server?  That's weird I've
had none with 3.0.3-5 serving and 3.0.6-2 as client, and I've copied
something like 200GB's of data off a samba mount (for a very time
sensitive app - no problems)...
Comment 6 Jay Fenlason 2004-09-16 15:42:10 EDT
Just to see what happens, try putting "use sendfile = no" in the 
[global] section of the server's smb.conf. 
Comment 7 Maciej Żenczykowski 2004-10-11 07:28:48 EDT
This isn't a 100% sure answer, but preliminary tests would suggest
that "use sendfile = no" does solve the problem.
Comment 8 Matthew Miller 2005-04-26 11:06:40 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 9 John Thacker 2006-10-28 13:12:38 EDT
Note that FC1 and FC2 are no longer supported even by Fedora Legacy.  Many
changes have occurred since these older releases.  Please install a supported
version of Fedora Core and retest.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.