Bug 1322552 - Self-heal and manual heal not healing some file
Summary: Self-heal and manual heal not healing some file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: 3.7.9
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Kotresh HR
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1317908 1321955
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-30 17:36 UTC by Kotresh HR
Modified: 2016-04-19 07:01 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of: 1321955
Environment:
Last Closed: 2016-04-19 07:01:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Kotresh HR 2016-03-30 17:38:37 UTC
Description of problem:

Rebooted one among the four gluster nodes, after the reboot when checked the "heal info" there were 6 files listed for healing. The files didn't heal by the self-heal daemon. Tried to perform manual heal, didn't succeed. 
Finally he need to run "gluster volume heal volname full" for the 6 files to get healed.
Environment : 

2x2 distributed replicated volume. 


Version-Release number of selected component (if applicable):


How reproducible:

One time issue. 

Steps to Reproduce:

N A 

Actual results:

The files didn't heal , until "gluster volume heal volname full" is executed. 


Expected results:

The files should either automatically heal, or can be manually heal by

Comment 2 Vijay Bellur 2016-03-30 17:54:51 UTC
REVIEW: http://review.gluster.org/13861 (features/changelog: Don't modify 'pargfid' in 'resolve_pargfid_to_path') posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 3 Vijay Bellur 2016-03-31 15:56:18 UTC
COMMIT: http://review.gluster.org/13861 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 5560961e5188c6b8f4b09d57245513a8f9612ff4
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Mar 29 19:06:46 2016 +0530

    features/changelog: Don't modify 'pargfid' in 'resolve_pargfid_to_path'
    
    Backport of http://review.gluster.org/#/c/13845/
    
    If 'changelog' is enabled and 'changelog.capture-del-path' option is on
    it calls 'resolve_pargfid_to_path' which modifies 'pargfid' sent by
    caller.  'changelog_unlink' calls this routine directly with
    'loc->pargfid' resulting it being modified and point to root instead of
    actual pargfid. This is a nasty bug and could cause the deletion of
    entry on root directory instead on actual parent when 'loc->path' is
    not present.  Hence this fix to make 'pargfid' a const pointer and
    'resolve_pargfid' to work on copy of pargfid.
    
    Glusterfind session creation enables these options by default to
    capture deleted entry path in changelog.
    
    Thanks Pranith for root causing this.
    
    BUG: 1322552
    Change-Id: I9f2bc44b5604b224462594c12b7d79e68198d693
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/13861
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 4 Kaushal 2016-04-19 07:01:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.