Bug 13226 - emu10k1 smp deadlock
Summary: emu10k1 smp deadlock
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-29 18:52 UTC by Matthew Galgoci
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:05:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Galgoci 2000-06-29 18:52:06 UTC
There is at least one deadlock caused by the emu10k1 driver on smp 
systems. It does not happen immediately, but is triggered when playing
music via xmms, but not always immediately.

I don't know that the driver has been updated since zab added it to the 
kernel rpm (still not in official kernel).

I have not been able to get an oops. I may try running a serial console 
later today to see if I can get one. (does a deadlock even cause an oops?)

Comment 1 Michael K. Johnson 2000-08-01 21:47:22 UTC
Try the kernel in Pinstripe; if that doesn't work, let me know and I'll
build or point you to something newer for you to try.

Comment 2 Alan Cox 2002-12-15 00:05:50 UTC
The SMP deadlocks were fixed in later releases. Mr Johnson forgot to close the
bug however.

Alan



Note You need to log in before you can comment on or make changes to this bug.