Bug 132261 - Migration Script Failure Due To Appletalk echo Service
Migration Script Failure Due To Appletalk echo Service
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: openldap (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
: 126711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 09:16 EDT by R. Michael Richer
Modified: 2015-01-07 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R. Michael Richer 2004-09-10 09:16:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
When migrating (using the migration scripts 
in /usr/share/openldap/migration) the services (migrate_services.pl) 
script will generate two "dn: cn=echo,ou=Services,dc=mirarco,dc=org" 
entries.  This will of course fail when it tries to migrate this.

The multiple entries are causes by having multiple "echo" lines 
in /etc/services.

The first two are OK:
    echo     7/tcp
    echo     7/udp

The next one will fail it:
    echo     4/ddp                 #AppleTalk Echo Protocol

Suggestions:
    i.) Update the script to add support for ddp on top of tcp and udp
       OR
    ii.) Remove the offending AppleTalk Echo Protocol Service Entry.

Option 2 is not advised as it will affect the support for a valid 
Appletalk Service.

Version-Release number of selected component (if applicable):
openldap-2.0.27-17

How reproducible:
Always

Steps to Reproduce:
1.  Execute the Migration Scripts With AppleTalk Support Installed
2.
3.
    

Actual Results:  It Failed

Expected Results:  It Should Import all 3 entries

Additional info:
Comment 1 Doncho N. Gunchev 2004-10-01 10:46:11 EDT
    This is much detailed description of bug # 126711 (duplicate). I
wonder if it is possible to have these three, but removing (commenting
out) the third one works. This is longstanding problem - RH9...FC3t2
and maybe from the begining of openldap...
Comment 2 Kenneth Porter 2005-05-25 22:30:31 EDT
The problem is that the 3rd service (protocol DDP) uses a different port number,
and the script assumes that all protocols use the same port number for the same
service name. &build_service_records works in port order so it doesn't realize
that the tcp/udp instances of echo have the same name as the ddp protocol and
doesn't try to generate aliases for them.

The nested loops in &build_service_records should probably loop first on
@protocols, and should artificially put tcp and udp ahead of any others in
priority, so that others (eg. ddp) are forced to use an alias.
Comment 3 Kenneth Porter 2005-05-25 22:55:51 EDT
A quick inspection of the current Rawhide package (2.2.23-5) suggests that the
problem is still there. I don't see a patch in the SRPM to address this and the
script from the raw script package is unchanged. (I need to update my libtool
and install bind-libbind-devel on FC2 before I can try to build and update to
the Rawhide package.)
Comment 4 John Thacker 2006-10-28 13:04:26 EDT
*** Bug 126711 has been marked as a duplicate of this bug. ***
Comment 5 RHEL Product and Program Management 2007-10-19 15:21:34 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.