Bug 132287 - XFree86-devel rpm missing from FC3 binary CD's
XFree86-devel rpm missing from FC3 binary CD's
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 12:14 EDT by Banibrata Dutta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 00:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Banibrata Dutta 2004-09-10 12:14:10 EDT
Description of problem:
While trying to install kdevelop rpm found dependencies missing, so 
tried to resolve them which led to the point where qt-designer could 
not be installed which inturn could not be installed because qt-devel 
could not be installed which in turn could not be installed because 
XFree86-devel was not installed.

Finally checked all the 4 CD's but didn't find XFree86-devel (or 
XFree86 anywhere). Because of this the whole chain of dependency is 
broken.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-09-10 15:17:09 EDT
xorg-x11-devel is what you need.
Comment 2 Banibrata Dutta 2004-09-11 02:40:25 EDT
Thanks Bill, but isn't it somehow incorrect (maybe needs to go into 
wishlist), that
  rpm -ivh <package-A>
reports that some <package-B> is required (from FC3 or any distro),
but there is no <package-B> in the distro ?? Or, there should be some
mechanism (similar to rpmfind.net) which can tie-in the <package-B> 
to <package-C> where <package-C> is a drop-in replacement for 
<package-B> ??

Of course this is not a XFree86 problem.
Comment 3 David Lawrence 2004-09-13 11:41:02 EDT
It would be a bug in the kdevelop package instead which needs to be
changed to require xorg-x11-devel instead of XFree86-devel. Since the
xorg-x11-devel package also provides for XFree86-devel as a legacy,
then most people don't see this problem if they already have it
installed. Changing component to kdevelop.


[dkl@mrhanky RPMS]$ rpm -qp --provides
xorg-x11-devel-6.7.99.903-6.i386.rpm
warning: xorg-x11-devel-6.7.99.903-6.i386.rpm: V3 DSA signature:
NOKEY, key ID 30c9ecf8
Mesa-devel
XFree86-devel = 4.4.0
libGL-devel = 1
libGL-devel = 1.2
libGLU-devel = 1
libGLU-devel = 1.3
xpm-devel
xorg-x11-devel = 6.7.99.903-6

Note You need to log in before you can comment on or make changes to this bug.