Bug 132289 - eggcups notification area icon doesn't go away
eggcups notification area icon doesn't go away
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 12:29 EDT by Michal Jaegermann
Modified: 2008-01-10 07:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 07:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-09-10 12:29:45 EDT
Description of problem:

With the single existing printer queue, which is of a type
"lpd on a remote machine", after printing on it a single file
(IIRC data were fed to 'lpr' from stdin) which prints in an
expected manner and with no indication of errors, I noticed after
a while that I have a new tiny icon on a toolbar.  A closer
examination reveals that it looks like a printer. Clicking on it
opens a window with a "Document print status" title.  It has one
line in it which says:

Unknown  lp   ?   1 hour and 5 minutes ago   Unknown

This apparently refers to my print job mentioned above as there
were no other candicates. "Edit" on that line offers options like
"Cancel Documents", "Pause Documents", "Resume Documents".
Regardless of what I am choosing and what I do in the followup
that does not seem to have any effects whatsoever.  'lpq' says:

lp is ready
no entries

and 'lpc' agrees with it. 'lprm' simply prints 'lprm: Unable to
cancel job(s)!' and 'lprm -' returns silently and no changes.

A machine reboot seems to clear the condition, or at least that
extra icon disappers, but this is a kind of a drastic action
for that.

Version-Release number of selected component (if applicable):
cups-1.1.21-1.rc2.1
Comment 1 Tim Waugh 2004-09-10 12:51:14 EDT
Fixing component.
Comment 2 Ben Konrath 2004-11-10 10:11:40 EST
I can confirm that this is still the case in FC3 final. 

% rpm -q libgnomecups cups-libs cups hal-cups-utils
libgnomecups-0.1.12-5
cups-libs-1.1.22-0.rc1.8
cups-1.1.22-0.rc1.8
hal-cups-utils-0.5.2-8
Comment 3 Colin Walters 2004-12-10 16:56:44 EST
So...this happens when you configure your local CUPS server to have a
queue which forwards to a remote machine's lpd queue?  What happens if
you browse to http://localhost:631/jobs ?
Comment 4 Michal Jaegermann 2004-12-10 20:11:13 EST
Well, with current "rawhide" http://localhost:631/jobs says
"No Active Jobs" and this small icon on a toolbar pops up a window
which says that some job was completed over eight hours ago.
Basically a pure visual noise but at least it does not says
"Unknown".
Comment 5 oll 2006-05-18 09:25:55 EDT
Still the same behaviour with FC5
Comment 6 Christoph Höger 2007-04-30 09:51:43 EDT
Hi,

i have still the same problem on FC6.
Obviously eggcups tries to connect to localhost:ipp instead of remotecups:ipp
where the printer is atually managed.
Eggcups has ipp status error 1280 one time and a lot 1030 (clearly localhost
won't be able to give some infos about a remote job)
This seems to be a real small but annoying bug, as lpq and lpstat and stuff all
wor well.

Any ideas how this could be fixed?  
Comment 7 Tim Waugh 2008-01-10 07:38:59 EST
eggcups no longer shipped.

Note You need to log in before you can comment on or make changes to this bug.