Bug 1322938 - compliance reports from a particular org should be visible when org context is set
Summary: compliance reports from a particular org should be visible when org context i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-31 17:37 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:36 UTC (History)
3 users (show)

Fixed In Version: foreman-1.11.0.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:29:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14458 None None None 2016-04-22 16:05:27 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Kedar Bidarkar 2016-03-31 17:37:42 UTC
Description of problem:

compliance reports from a particular org should be visible when org context is set. Currently Compliance reports are not visible unless "Any Organization" is set.

Version-Release number of selected component (if applicable):
sat62-snap6

How reproducible:


Steps to Reproduce:
1. Run "foreman_scap_client <policy_id>" on the client
2. See that the compliance reports are visible only under "any organization" context.
3.

Actual results:
compliance reports are visible only under "any organization" context.

Expected results:
compliance reports should be  visible under their respective ORganization context.

Additional info:

Comment 2 Shlomi Zadok 2016-04-01 09:49:26 UTC
I believe the reports organization are coupled with their respective host's organization. Can you please verify that the host belongs to an organization?

Comment 3 Kedar Bidarkar 2016-04-01 15:18:28 UTC
Yes the hosts do belong to "Default Organization", but still we cannot see the reports unless we set "Any org" as the Org context.

Comment 4 Shlomi Zadok 2016-04-04 10:14:39 UTC
Created redmine issue http://projects.theforeman.org/issues/14446 from this bug

Comment 6 Shlomi Zadok 2016-04-06 08:11:51 UTC
Please note that http://projects.theforeman.org/issues/14458 solves the issue.

Comment 7 Ohad Levy 2016-04-06 08:37:19 UTC
please cherrypick the fix from http://projects.theforeman.org/issues/14458, it will also find its way to upstream 1.11.1.

Comment 9 Kedar Bidarkar 2016-04-15 15:27:44 UTC
VERIFIED with sat62-snap8.1

I had set the org-context, "Default Organization", "any ORg", "kbidarka_org".
Depending upon the org context the compliance reports were visible,

Comment 11 errata-xmlrpc 2016-07-27 09:29:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.