Bug 1322990 - compliance report searches fails
Summary: compliance report searches fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-31 21:16 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:36 UTC (History)
3 users (show)

Fixed In Version: rubygem-foreman_openscap-0.5.3.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:30:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14478 None None None 2016-04-06 15:20:49 UTC
Foreman Issue Tracker 14504 None None None 2016-04-06 15:02:32 UTC

Description Kedar Bidarkar 2016-03-31 21:16:20 UTC
Description of problem:
compliance report searches fails when searching for reports related to 

compliance_failed, compliance_passed to name a few, there are isues with many other searches as well.




2016-03-31 22:21:58 [app] [I] Started GET "/compliance/arf_reports?utf8=%E2%9C%93&search=+compliance_failed+" for 10.10.52.71 at 2016-03-31 22:21:58 -0400
2016-03-31 22:21:58 [app] [I] Processing by ArfReportsController#index as HTML
2016-03-31 22:21:58 [app] [I]   Parameters: {"utf8"=>"✓", "search"=>" compliance_failed "}
2016-03-31 22:21:58 [app] [W] Action failed
 | NoMethodError: undefined method `klass' for nil:NilClass
 | /opt/theforeman/tfm/root/usr/share/gems/gems/scoped_search-3.2.2/lib/scoped_search/definition.rb:62:in `klass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/scoped_search-3.2.2/lib/scoped_search/definition.rb:82:in `column'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/scoped_search-3.2.2/lib/scoped_search/definition.rb:96:in `type'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/scoped_search-3.2.2/lib/scoped_search/definition.rb:214:in `block in default_fields_for'


Version-Release number of selected component (if applicable):
sat62-snap6

How reproducible:


Steps to Reproduce:
1. try to search compliance reports with some criteria in the search box.
2.
3.

Actual results:
search throws a message on the UI.

Oops, we're sorry but something went wrong undefined method `klass' for nil:NilClass

Expected results:
Search should be handled properly
Search should not throw an error on the UI and traceback in the log file.

Additional info:

Comment 2 Shlomi Zadok 2016-04-05 13:01:17 UTC
Created redmine issue http://projects.theforeman.org/issues/14478 from this bug

Comment 4 Bryan Kearney 2016-04-05 14:11:46 UTC
Upstream bug assigned to szadok@redhat.com

Comment 5 Kedar Bidarkar 2016-04-05 16:07:55 UTC
I feel this should remain as a blocker for GA, as after running OSCAP for many hosts ( For example: 100+ or so ), if the user is unable to determine quickly  what hosts are compliant and non-compliant, it really becomes difficult to get an idea about it.

Comment 9 Kedar Bidarkar 2016-04-15 15:32:00 UTC
VERIFIED With sat62-snap8.1

Had in total 2 compliance reports which had 9 passed and 29 failed

Searched with compliance_failed > 28   and results shown had both the reports. 
Searched with compliance_passed > 8 and results shown had both the reports.

Searched with compliance_failed > 29   and results shown had no reports. 
Searched with compliance_passed > 9 and results shown had no reports.

Comment 11 errata-xmlrpc 2016-07-27 09:30:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.