Bug 132301 - subscripts out of range
subscripts out of range
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: oprofile (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 14:46 EDT by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 13:08:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-09-10 14:46:02 EDT
Description of problem:

I just tried to compile package oprofile-0.8-20040511.11 from
Redhat Fedora Core 3 Test 1.

The compiler said

1.

op_regex.cpp(288): warning #175: subscript out of range

The source code is

	throw bad_regex("invalid input file: " + '"' + line + '"');

Suggest code

	throw bad_regex("invalid input file: " + "\"" + line + "\"");


2.

op_regex.cpp(296): warning #175: subscript out of range
op_regex.cpp(307): warning #175: subscript out of range

Duplicates.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 William Cohen 2004-09-13 13:43:29 EDT
I have been unable to replicate this. On FC3 test 1 on AMD64 machine.
What is the build environment, FC3 test1? What version of gcc/g++ and
related libraries are being used.

-Will
Comment 2 William Cohen 2004-09-15 13:08:31 EDT
I also tried to replicate on a i386 (Pentium III) machine running FC3
with latest updates (september 14, 2004). I was unable to replicate
this problem. oprofile built without any problems.

Note You need to log in before you can comment on or make changes to this bug.