Bug 1323017 - Ordering query results from libgfdb
Summary: Ordering query results from libgfdb
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
Assignee: sankarshan
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1330354
TreeView+ depends on / blocked
 
Reported: 2016-04-01 01:30 UTC by Joseph Elwin Fernandes
Modified: 2016-06-28 12:13 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1330354 (view as bug list)
Environment:
Last Closed: 2016-06-28 12:13:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joseph Elwin Fernandes 2016-04-01 01:30:50 UTC
Description of problem:
When querying always order the result to have hotest or coldest files on the top w.r.t demotion or promotion.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-04-01 01:37:21 UTC
REVIEW: http://review.gluster.org/13881 (tier/libgfdb: Ordering query results from libgfdb) posted (#1) for review on release-3.7 by Joseph Fernandes

Comment 2 Vijay Bellur 2016-04-26 21:51:08 UTC
COMMIT: http://review.gluster.org/13881 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 681d4590bd7e13b742c399573da55c509eb5b2a2
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Fri Mar 4 08:55:09 2016 +0530

    tier/libgfdb: Ordering query results from libgfdb
    
    When querying we will order the query result to get
    the hotest or the coldest files in the queried list
    so that these files are migrated first.
    
    Now here we are giving priority to the write heat(time and counters),
    as it requires complex queries to have a composite
    ordering of write and read + it has it impact on performance.
    
    Backport of http://review.gluster.org/13607
    
    > Change-Id: I2e0415dcfad4218b42c68fc5c2ed8d1f075ce9ea
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/13607
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: Joseph Fernandes
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: If5fad07f8d0f50016b10e256803abd5266cd708f
    BUG: 1323017
    Reviewed-on: http://review.gluster.org/13881
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 5 Kaushal 2016-06-28 12:13:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.