Bug 1323033 - Epson inkjet driver RPM does not advertise the printers it supports
Summary: Epson inkjet driver RPM does not advertise the printers it supports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: epson-inkjet-printer-escpr
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-01 04:05 UTC by Sitsofe Wheeler
Modified: 2016-07-13 03:04 UTC (History)
3 users (show)

Fixed In Version: epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc22 epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of: 1282446
Environment:
Last Closed: 2016-07-13 03:04:56 UTC


Attachments (Terms of Use)

Description Sitsofe Wheeler 2016-04-01 04:05:51 UTC
Description of problem:
When trying to add an Epson WF-3520 printer an "Additional Printer Drivers Required" prompt appeared but clicking it resulted in an error message.

Version-Release number of selected component (if applicable):
control-center-3.18.1-1.fc23.x86_64
epson-inkjet-printer-escpr-1.5.2-1.1lsb3.2.fc23.x86_64
PackageKit-1.0.10-1.fc23.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. Run
gnome-control-center printers
.
2. Click the Unlock button at the top right.
3. Click the + button at the bottom left.
4. Wait for the networked WF-3520 printer to appear.
5. In the "Add a New Printer" dialog select the WF-3520 printer and click the Add button at the bottom right.

Actual results:
A notification appears at the top of the screen saying "Additional Printer Drivers Required" but the Model in the Printers window is filled in with "Generic ESC/P Dot Matrix Printer" or "Generic text-only printer". Clicking the notification and choosing "Find in software" results in a window called "Unable to Find Requested Software" and a message "Unfortunately, the EPSON WF-3520 Series you were searching for could not be found. Please see this website for more information." (but the text itself is not selectable). The following is visible in journal --user:
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: /usr/share/system-config-printer/scp-dbus-service.py:26: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: from gi.repository import Gdk
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: /usr/share/system-config-printer/scp-dbus-service.py:27: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: from gi.repository import Gtk
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: /usr/share/system-config-printer/jobviewer.py:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: from gi.repository import Notify
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: /usr/share/system-config-printer/jobviewer.py:55: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: from gi.repository import GnomeKeyring
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: No ID match for device lpd://192.0.2.1:515/PASSTHRU:
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: MFG:EPSON;MDL:WF-3520 Series;CMD:ESCPL2,BDC,D4,D4PX,ESCPR1;DES:EPSON WF-3520 Series;
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: No ID match for device lpd://192.0.2.1:515/PASSTHRU:
Nov 16 07:27:55 localhost org.fedoraproject.Config.Printing[1472]: MFG:EPSON;MDL:WF-3520 Series;CMD:ESCPL2,BDC,D4,D4PX,ESCPR1;DES:EPSON WF-3520 Series;

Expected results:
A notification to appear, for the process to wait for me to acknowledge the notification and for it to be suggested that I install the epson-inkjet-printer-escpr package and after installing it for it to be used as the selected model.

Additional info:
This problem seems to be due to the epson-inkjet-printer-escpr RPM not indicating what printer drivers it provides:

$ rpm -q --provides hplip | head
hpijs = 1:3.16.2-1.fc23
hplip = 3.16.2-1.fc23
hplip(x86-64) = 3.16.2-1.fc23
postscriptdriver(apollo;apollo_2100;)
postscriptdriver(apollo;apollo_2150;)
postscriptdriver(apollo;apollo_2200;)
postscriptdriver(apollo;apollo_2500;)
postscriptdriver(apollo;apollo_2600;)
postscriptdriver(apollo;apollo_2650;)
postscriptdriver(apollo;apollo_p2000-u;)

$ rpm -q --provides epson-inkjet-printer-escpr | head
epson-inkjet-printer-escpr = 1.5.2-1.1lsb3.2.fc23
epson-inkjet-printer-escpr(x86-64) = 1.5.2-1.1lsb3.2.fc23
libescpr.so.1()(64bit)

Without the provides Packagekit has no idea what to install.

https://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation indicates this information can be extracted automatically:

'To ensure a printer driver's binary RPMs are given postscriptdriver() tags, add "BuildRequires: python-cups, cups" to the RPM spec file.

Fedora 21
Starting with Fedora 21, this should be "BuildRequires: python3-cups, cups"'

to the spec file. Inspecting the current spec file (https://apps.fedoraproject.org/packages/epson-inkjet-printer-escpr/sources/spec/ ) turns up this:

%if 0%{?rhel} == 6
# For dir ownership
Requires:       cups
%else
# For dir ownership
Requires:	cups-filesystem
# So that automatic printer driver installation works
BuildRequires:	python-cups
%endif

So it looks like python-cups needs to be python3-cups and a BuildRequires on cups itself is missing when we aren't building a RHEL6 package...

This issue is spun off from Bug #1282446 .

Comment 1 Susi Lehtola 2016-04-01 05:48:08 UTC
Next time please don't hide the issue under a wall of irrelevant text. I almost reclassified the bug.

Missing BR on python3-cups added in epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.

Comment 2 Fedora Update System 2016-04-01 06:02:06 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-59dfcc5f3c

Comment 3 Fedora Update System 2016-04-01 06:02:12 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5d5e4d819c

Comment 4 Fedora Update System 2016-04-01 06:02:18 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-abaae1de7d

Comment 5 Fedora Update System 2016-04-01 06:02:23 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-df9fa8a505

Comment 6 Fedora Update System 2016-04-02 05:20:52 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-df9fa8a505

Comment 7 Fedora Update System 2016-04-02 05:26:10 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-59dfcc5f3c

Comment 8 Fedora Update System 2016-04-02 08:49:49 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-abaae1de7d

Comment 9 Fedora Update System 2016-04-02 08:50:31 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5d5e4d819c

Comment 10 Fedora Update System 2016-04-10 14:22:14 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-04-10 14:22:56 UTC
epson-inkjet-printer-escpr-1.6.4-1.1lsb3.2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-04-25 03:25:57 UTC
epson-inkjet-printer-escpr-1.6.5-1.1lsb3.2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-62625f1a09

Comment 13 Fedora Update System 2016-04-25 03:26:23 UTC
epson-inkjet-printer-escpr-1.6.5-1.1lsb3.2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-2b83caa4e1

Comment 14 Fedora Update System 2016-04-26 00:19:59 UTC
epson-inkjet-printer-escpr-1.6.5-1.1lsb3.2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-62625f1a09

Comment 15 Fedora Update System 2016-04-26 00:24:14 UTC
epson-inkjet-printer-escpr-1.6.5-1.1lsb3.2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-2b83caa4e1


Note You need to log in before you can comment on or make changes to this bug.