Bug 132306 - ldd displays nothing for protected executables
ldd displays nothing for protected executables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 15:25 EDT by Jason Vas Dias
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 17:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2004-09-10 15:25:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
 
 ldd displays no output for executables such as named, dhcpd
 which do not have "unlabeled_t" read access in enforcing mode.
 Doing "setenforce 0" allows ldd to display output.

 The audit2allow message obtained is :
 "allow named_t unlabeled_t:file { read; };"

 


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.11-2

How reproducible:
Always

Steps to Reproduce:
1. Run selinux in enforcing mode
2. Enter the command:
   $ ldd /usr/sbin/named 
    or
   $ ldd /usr/sbin/dhcpd
   (or for any protected executable)

    

Actual Results:  No output is displayed, and an audit message appears
in /var/log/messages.

Expected Results:  ldd should display of list of linked libraries as
for other executables.

Additional info:

Dan Walsh asked me to raise this bug.
Comment 1 Daniel Walsh 2004-09-17 13:35:56 EDT
Fixed in glibc-2.3.3-54
Comment 2 Jason Vas Dias 2004-09-21 12:25:20 EDT
 Still happening with glibc-2.3.3-54 and 
 selinux-policy-targeted-1.17.18-3 .
Comment 3 David Juran 2005-04-12 14:31:11 EDT
I can't reproduce this with glibc-2.3.5-0.fc3.1 and
selinux-policy-targeted-1.23.8-2 any longer, so it seems to me like this can be
closed as fixed-rawhide.

Note You need to log in before you can comment on or make changes to this bug.