Bug 1323271 - It could be great to update status of product subscriptions after an action "update facts"
Summary: It could be great to update status of product subscriptions after an action "...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: All
OS: All
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-01 16:32 UTC by Jan Stavel
Modified: 2017-08-01 19:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:18:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Status of system is yellow after updating facts on GUI (219.30 KB, image/png)
2017-04-13 10:56 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1472 None None None 2016-09-06 13:12:32 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Jan Stavel 2016-04-01 16:32:31 UTC
Description of problem:

After an action "Update facts" was perfomerd subscription-manager-gui does not update a status of product subscriptions.


Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 6.8 Beta (Santiago)
----------------------------------------
server type                      Red Hat Subscription Management
subscription management server   0.9.51.15-1
subscription management rules    5.15.1
subscription-manager             1.16.8-8.el6
python-rhsm                      1.16.6-1.el6
----------------------------     ----------------------------
Product                          69.pem
135.pem
----------------------------     ----------------------------
Entitlement                      8657093875891931356.pem
----------------------------     ----------------------------

How reproducible:


Steps to Reproduce

    I am trying to play with partial covered products.
    I subscribed with SKU:

    | name | Red Hat Enterprise Linux, Premium L3 (up to 2 sockets) |
    | SKU  | MCT0924                                                |

    An account =stage_jstavel_demo01= consists of this SKU.

    I run subscription-manager-gui.

    I upgraded sockets:

    #+BEGIN_SRC shell
    echo '{"virt.is_guest":"false", "cpu.cpu_socket(s)":"4"}' > /etc/rhsm/facts/socket.facts
    subscription-manager facts --update
    #+END_SRC

    #+RESULTS:
    : Successfully updated the system facts.

    I updated facts : System -> View System Facts -> Update Facts.

    I still see a green icon next to "Red Hat Enterprise Linux Server".

    It could be helpfull that subscription-manager-gui refreshes a status of products after it updates facts.

    - ie. an icon next to "Red Hat Enteprise Linux Server" turns yellow after I click "Update Facts".

Actual results:

After an action "Update facts" subscription-manager-gui does not update status of product subscriptions.


Expected results:

Icon should be yellow (partially covered product) - since I upgraded num of CPUs.

Additional info:

Comment 4 Shwetha Kallesh 2017-04-13 10:56:09 UTC
Created attachment 1271411 [details]
Status of system is yellow after updating facts on GUI

[root@dhcp35-160 product]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.7-1.el7
python-rhsm: 1.19.4-1.el7

Comment 5 errata-xmlrpc 2017-08-01 19:18:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.