Bug 132330 - request for a "ccsd update cluster.conf" command
request for a "ccsd update cluster.conf" command
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
GFS Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 17:44 EDT by Corey Marthaler
Modified: 2009-04-16 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 18:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2004-09-10 17:44:28 EDT
Description of problem:
It would really be nice for ccsd users if there was an actual "ccsd
update the cluster.conf file" command. This way it could actually tell
you wheither or not your changes made it out to all the nodes or not. 

Currently one has to find ccsd's pid, send it a signal, check the
SYSLOGs on all nodes, and then check the cluster.conf files on all
nodes to see if it really worked or not.
Comment 1 Jonathan Earl Brassow 2004-09-13 10:34:41 EDT
I will make said script for you - it involves a couple other small things (like 
automatically notifying cman or gulm of the changes)...

For now, just do

#!/bin/bash

killall -HUP ccsd
if[ -e /etc/cluster/cluser.conf-rej]; then
  echo "Update failed.  Consult /var/log/messages for the reason.";
  echo "  Your changes have been saved in /etc/cluster/cluster.conf-rej";
else
  echo "Update succeeded."
fi

Comment 2 Kiersten (Kerri) Anderson 2004-11-04 10:07:25 EST
Updates with the proper version and component name.
Comment 3 Kiersten (Kerri) Anderson 2004-11-04 10:15:40 EST
Updates with the proper version and component name.
Comment 4 Kiersten (Kerri) Anderson 2004-11-04 10:20:28 EST
Updates with the proper version and component name. Again, just love out tools.
Comment 5 Jonathan Earl Brassow 2004-12-22 18:11:52 EST
ccs_tool update [new_cluster.conf]

will update and report results

It does not yet tell cman to update.
Comment 6 Corey Marthaler 2005-01-05 16:32:23 EST
when the update fails (for instance if ccsd dies on another node) this
script tells you to search the logs for your answer why, it'd be nice
if it reported that error so one doens't have to search n number of logs.

[root@morph-04 root]# ccs_tool update
Cluster update failed.

Update failed on remote nodes.
Check their logs for clues.
Comment 7 Jonathan Earl Brassow 2005-01-11 18:42:42 EST
update tool is available.

Openning new bug to reflect remaining gripe.
Comment 8 Corey Marthaler 2005-01-12 18:03:19 EST
verified availability. :)

Note You need to log in before you can comment on or make changes to this bug.