Bug 132331 - Missing libselinux-devel as build dependency
Summary: Missing libselinux-devel as build dependency
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-10 21:49 UTC by Eli
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-11 21:34:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eli 2004-09-10 21:49:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
rpmbuild --rebuild of vim-6.2.457-1.src.rpm fails (missing selinux.h) unless libselinux-devel is installed, but libselinux-devel is not a build dependency of vim.


Version-Release number of selected component (if applicable):
6.2.457-1

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild vim-6.2.457-1.src.rpm
2.
3.
    

Actual Results:  Build failure due to missing selinux.h

Expected Results:  Expected it to rebuild the various vim packages.

Additional info:

Comment 1 Karsten Hopp 2004-09-11 21:34:23 UTC
fixed in the development branch: 
%if %{WITH_SELINUX} 
Buildrequires: libselinux-devel 
%endif 
 


Note You need to log in before you can comment on or make changes to this bug.