Bug 1323328 - Module sh431 doesn't work as expected
Summary: Module sh431 doesn't work as expected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-01 21:49 UTC by Viacheslav Dubrovskiy
Modified: 2018-04-06 18:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-06 18:34:28 UTC


Attachments (Terms of Use)

Description Viacheslav Dubrovskiy 2016-04-01 21:49:35 UTC
Description of problem:
There are USB to serial adapter HL-340, which use module ch341. If connect it to console of any ciso devices, it doesn't work.

Steps to Reproduce:
1. Insert converter and connect to console port of cisco switch Catalist 2960.
2. Run minicom and set Bps/Par/Bits : 9600 8N1 on port settings

Actual results:
Show nothing.

Expected results:
Information from device

Additional info:
In the network there are many descriptions of the problem.Everything start working if apply this patch:
https://github.com/karlp/ch341-linux/blob/master/0001-usb-serial-ch341-Add-parity-support.patch

There are discussed in linux-usb group:
http://www.spinics.net/lists/linux-usb/msg105238.html
But patch was not applied.
Please, make me happy and Fedora better :)
Thank you.

Comment 1 Josh Boyer 2016-04-11 14:13:17 UTC
(In reply to Viacheslav Dubrovskiy from comment #0)
> Description of problem:
> There are USB to serial adapter HL-340, which use module ch341. If connect
> it to console of any ciso devices, it doesn't work.
> 
> Steps to Reproduce:
> 1. Insert converter and connect to console port of cisco switch Catalist
> 2960.
> 2. Run minicom and set Bps/Par/Bits : 9600 8N1 on port settings
> 
> Actual results:
> Show nothing.
> 
> Expected results:
> Information from device
> 
> Additional info:
> In the network there are many descriptions of the problem.Everything start
> working if apply this patch:
> https://github.com/karlp/ch341-linux/blob/master/0001-usb-serial-ch341-Add-
> parity-support.patch
> 
> There are discussed in linux-usb group:
> http://www.spinics.net/lists/linux-usb/msg105238.html
> But patch was not applied.
> Please, make me happy and Fedora better :)
> Thank you.

Upstream requested changes and the original author never followed up as far as I can tell.  We can't apply this as-is.

Moving this bug to rawhide as it needs to be fixed there first if we get to it.

Comment 2 Diego 2016-07-25 07:57:21 UTC
Maybe duplicate of #1235715

Comment 3 Alvin Austin 2016-09-25 20:20:44 UTC
This bug still exists with kernels 
4.7.3.200-fc24.x86_64 and 
4.7.4.200-fc24.x86_64

Comment 4 Alvin Austin 2016-10-21 15:18:52 UTC
This has not been fixed with the Fedora 25 Beta 1 release.

Kernel 4.8.0-0.rc7.git0.1.fc25.x86_64

USB-Serial Adapter
driver: ch341
idVendor=1a86, idProduct=7523

The chipset is recognized, and the ch341 kernel module is loaded, but the baud rate is not set correctly, and so garbage is sent/received through the usb/serial adapter instead of valid characters (for instance with minicom).

Comment 5 Alvin Austin 2017-05-10 17:57:40 UTC
Fixed. Thanks. See:
https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1235715


Note You need to log in before you can comment on or make changes to this bug.