Bug 1323405 - missing libspnav.so.0 and libzipios++.so.0 at runtime
Summary: missing libspnav.so.0 and libzipios++.so.0 at runtime
Keywords:
Status: CLOSED DUPLICATE of bug 1323159
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-02 15:06 UTC by Przemek Klosowski
Modified: 2019-01-09 12:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 12:31:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Przemek Klosowski 2016-04-02 15:06:55 UTC
Description of problem:
after successful installation of freecad, it won't run

Version-Release number of selected component (if applicable):
freecad-0.15-12.fc24.x86_64

How reproducible: every time

Steps to Reproduce:
1. dnf install freecad
2. FreeCAD

Actual results:
FreeCAD: error while loading shared libraries: libspnav.so.0: cannot open shared object file: No such file or directory

Expected results: successful run of FreeCAD

Comment 1 Przemek Klosowski 2016-04-02 15:10:40 UTC
libspnav.so.0 is provided by package libspnav , so freecad is somehow missing this dependency. 

After manually installing 'dnf install libspnav', FreeCAD still doesn't run, because it misses another dependency on libzipios.so.0 , which is provided by zipios++

Unfortunately, after 'dnf install zipios++' FreeCAD still doesn't run because it segfaults. I'll file a separate bug on that.

Comment 2 Richard Shaw 2016-04-03 18:42:01 UTC
I'll have to dig into why this occurred, this has not been a problem on other releases in the past and the spec file hasn't change as far as dependencies are concerned.

Comment 3 Richard Shaw 2016-04-03 20:54:21 UTC
Looking at the Koji builds something must have lost it's mind, there are no library based dependencies in any of the f24 builds, f23 looks fine.

Comment 4 Richard Shaw 2016-04-04 12:31:52 UTC

*** This bug has been marked as a duplicate of bug 1323159 ***


Note You need to log in before you can comment on or make changes to this bug.