Bug 1323408 - freecad segfaults on startup
Summary: freecad segfaults on startup
Keywords:
Status: CLOSED DUPLICATE of bug 1323159
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-02 16:07 UTC by Przemek Klosowski
Modified: 2019-01-09 12:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 12:31:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Przemek Klosowski 2016-04-02 16:07:38 UTC
Description of problem: freecad segfaults on startup

Version-Release number of selected component (if applicable):
freecad-0.15-12.fc24.x86_64

How reproducible:every time

Steps to Reproduce:
1. FreeCAD

Actual results:
Starting program: /usr/bin/FreeCAD 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
FreeCAD 0.15, Libs: 0.15R4671 (Git)
.....
Program received signal SIGSEGV, Segmentation fault.
cc_memalloc_deallocate (allocator=0x3104200042043504, ptr=ptr@entry=0xb6fcd0) at memalloc.cpp:187
187	  newfree->next = allocator->free;
(gdb) where
#0  cc_memalloc_deallocate (allocator=0x3104200042043504, ptr=ptr@entry=0xb6fcd0) at memalloc.cpp:187
#1  0x00007ffff43926b6 in SbHashEntry<short, char const*>::operator delete (ptr=0xb6fcd0) at ../../src/misc/SbHash.h:89
#2  SbHash<short, char const*>::resize (newsize=<optimized out>, this=0xb41050) at ../../src/misc/SbHash.h:322
#3  SbHash<short, char const*>::put (obj=<optimized out>, key=<optimized out>, this=0xb41050) at ../../src/misc/SbHash.h:226
#4  SoType::createType (parent=..., name=..., method=method@entry=0x7ffff4207e60 <SoTransparencyElement::createInstance()>, 
    data=data@entry=0) at SoType.cpp:296
#5  0x00007ffff4207f0b in SoTransparencyElement::initClass () at SoTransparencyElement.cpp:50
#6  0x00007ffff41edc6f in SoElement::initElements () at SoElement.cpp:449
#7  0x00007ffff41eddbf in SoElement::initClass () at SoElement.cpp:517
#8  0x00007ffff437db5e in SoDB::init () at SoDB.cpp:290
#9  0x00007ffff751c011 in Gui::Application::runApplication () at /usr/src/debug/freecad-0.15.4671/src/Gui/Application.cpp:1680
#10 0x00000000004041b0 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/freecad-0.15.4671/src/Main/MainGui.cpp:330
(gdb) p allocator->free
Cannot access memory at address 0x3104200042043504

Comment 1 Richard Shaw 2016-04-04 12:31:58 UTC

*** This bug has been marked as a duplicate of bug 1323159 ***


Note You need to log in before you can comment on or make changes to this bug.