Bug 132343 - i386 firefox segfaults on Java sites
i386 firefox segfaults on Java sites
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 23:20 EDT by Erich Hoover
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 22:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Hoover 2004-09-10 23:20:57 EDT
Description of problem:
Loading a website with a Java applet causes Firefox to segfault.  This
does not occur with the official binaries.

Version-Release number of selected component (if applicable):
firefox-0.9.3-8

How reproducible:
Always

Steps to Reproduce:
1. Install Firefox from RPM instead of binary
2. Copy Java plugin to ~/.mozilla/plugins/
3. Open Firefox and load a Java website
  
Actual results:
Firefox completely closes and leaves information on the console (if
run from console - see additional info).  Please note that the
mplayerplug-in errors are due to the 64-bit mplayer plugin being in
the same global plugin folder.  Workaround: Use official binaries or
64-bit browser w/ no Java.

Expected results:
Firefox opens the webpage.

Additional info:
(firefox-bin:23451): Gtk-WARNING **: Unable to locate theme engine in
module_path: "bluecurve",
LoadPlugin: failed to initialize shared library
/usr/lib/firefox-0.9.3/plugins/mplayerplug-in.so
[/usr/lib/firefox-0.9.3/plugins/mplayerplug-in.so: cannot open shared
object file: No such file or directory]
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: No such file or directory
Comment 1 Warren Togami 2004-09-18 23:08:34 EDT
We need more details.  Exactly what version of java is this?  Please
retest it with 64bit plugins fully removed, firefox debuginfo
installed, and get a gdb backtrace.

Is this an issue running the same on a pure 32bit system?
Comment 2 Erich Hoover 2004-09-19 14:35:34 EDT
Is there a way I can install the debuginfo without downloading the
source package and manually compiling it?  I run into problems
attempting this.  I downloaded the source package, extracted it,
switched to the folder, created a 32-bit environment ('linux32 su'),
configured, and tried to make and ran into problems after a while:
{standard input}: Assembler messages:
{standard input}:167: Error: suffix or operands invalid for `push'
{standard input}:177: Error: suffix or operands invalid for `push'
{standard input}:183: Error: suffix or operands invalid for `pop'
Comment 3 Warren Togami 2004-09-19 17:14:26 EDT
Ah crap... I just remembered that our firefox debuginfo package is
broken. =(
Comment 4 Erich Hoover 2004-09-23 00:29:26 EDT
Whatever was causing the problem is fixed in the 1.0 Preview Release
available in RAWHIDE.
Comment 5 Christopher Aillon 2004-09-26 22:27:19 EDT
Ok, then marking RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.