Red Hat Bugzilla – 1323450 – [z-stream clone - 3.6.5] java.lang.IllegalArgumentException: No type specified for option: 'encrypt_options' in /api/capabilities
Note that in order to test and verify this you will need to force an error in the configuration. To do so manually perform the following update in the database:
update vdc_options set option_value='secure=bool,port=int,slot=int' where option_name='VdsFenceOptionTypes'
Then restart the engine, and once it is running again request the API capabilities resource:
GET /ovirt-engine/api/capabilities
That used to fail but should succeed now, and the following error message should appear in engine.log:
ERROR: No type specified for fencing option "encrypt_options".
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHBA-2016-0661.html