Bug 132349 - [EASY] Add Belkin F5D6020 PCMCIA info to /etc/pcmcia/config
[EASY] Add Belkin F5D6020 PCMCIA info to /etc/pcmcia/config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-11 02:31 EDT by Dan Williams
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 17:46:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-09-11 02:31:30 EDT
Easy to add:

device "pcmf502rd"
  class "network" module "pcmf502rd"

card "Belkin F5D6020 rev.2"
  manfid 0x1bf, 0x3302
  bind "pcmf502rd"

The only thing is that we don't actually _ship_ the pcmf502* drivers,
for which upstream is http://atmelwlandriver.sourceforge.net/news.html
.  The drivers seem to work fine with my card so far.

Bill, would you have a problem with adding this info even though we
don't ship the drivers?  Its one less step people would have to take.
 If you'd like me to do this and build a new hwdata RPM, I can do that
too.
Comment 1 Dan Williams 2004-09-11 02:49:25 EDT
Note that the reason "atmel_cs" and "pcmf502*" are different is that
they support a slightly different subset of cards.  The atmel_cs
driver does detect the Belkin card, but requires firmware to be
uploaded.  The pcmf502* driver does _not_ require firmware upload and
is therefore more usable in some respects.
Comment 2 Dan Williams 2004-09-11 09:47:12 EDT
Wait on this one, it seems that the "atmel_cs" driver _DOES_ support
this card, but there are issues to be resolved.  Like the "atmel_cs"
driver explicitly tries to upload firmware to the card, but it doesn't
really seem to _need_ that.

Obviously, if atmel_cs would work we should use that because we ship it.
Comment 3 Bill Nottingham 2004-09-13 12:24:17 EDT
OK, holding off for now. :)
Comment 4 Dan Williams 2004-10-11 17:46:49 EDT
Done, pointed at atmel_cs driver

Note You need to log in before you can comment on or make changes to this bug.