Bug 1323545 - Need a statically reserved uid and gid for heketi [NEEDINFO]
Summary: Need a statically reserved uid and gid for heketi
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: setup
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1306914
TreeView+ depends on / blocked
 
Reported: 2016-04-04 02:05 UTC by Luis Pabón
Modified: 2016-11-08 22:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-09 06:52:41 UTC
Type: Bug
ovasik: needinfo? (lpabon)


Attachments (Terms of Use)

Description Luis Pabón 2016-04-04 02:05:59 UTC
Description of problem:
    user/group: heketi
    package responsible for the user/group creation: heketi
    shell, if something other than /sbin/nologin: /sbin/nologin
    home directory, if applicable: <none>


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ondrej Vasik 2016-04-04 13:30:26 UTC
Thanks for report. However, I'm no longer allowed to make static uid/gid reservations myself. Please open a ticket for fpc ( https://fedorahosted.org/fpc/ ) and link it to this bugzilla. You will be definitely asked for justification why you need static uid/gid and why is dynamic id not sufficient for heketi. Please be prepared to provide such justification (ideally, please provide this justification when submitting this fpc ticket).

Setting needinfo to reporter, as I need the link to fpc ticket. If not provided, I'll close this bugzilla in ~2-3 months.

Comment 2 Luis Pabón 2016-04-12 12:57:19 UTC
Ticket # : https://fedorahosted.org/fpc/ticket/619

Comment 3 Jan Kurik 2016-07-26 04:53:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 4 Ondrej Vasik 2016-07-26 12:26:02 UTC
Luis, FPC ticket waits for your justification/input. It is stalled for 3 months now - if you don't have any special reason for static ID, I suggest to go with dynamic ID allocation instead and close both this bz and FPC ticket as not a bug.

Comment 5 Ondrej Vasik 2016-09-09 06:52:41 UTC
Closing WONTFIX, as the fpc ticket and this bugzilla is without any response for 4+ months. Feel free to reopen once fpc ticket is approved (when sufficient justification is provided there).


Note You need to log in before you can comment on or make changes to this bug.