Bug 1323639 - [API] GET `system/summary` return no data if there is no existing cluster
Summary: [API] GET `system/summary` return no data if there is no existing cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: anmol babu
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 10:13 UTC by Daniel Horák
Modified: 2016-08-23 19:49 UTC (History)
0 users

Fixed In Version: rhscon-core-0.0.17-1.el7scon.x86_64.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:49:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 274871 None None None 2016-05-06 08:44:31 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-04-04 10:13:01 UTC
Description of problem:
  API GET call `system/summary` doesn't work properly when there is no existing cluster in USM.

Version-Release number of selected component (if applicable):
  rhscon-ceph-0.0.8-1.el7.x86_64
  rhscon-core-0.0.11-1.el7.x86_64
  rhscon-ui-0.0.25-1.el7.noarch

How reproducible:
  100%

Steps to Reproduce:
1. Prepare and install skyring on the server (accordingly to DOC).
2. Use API call to get system summary (see script in Additional info).
3. Accept some nodes and create cluster from them.
4. Again call API request to get system summary (as in step 2.)

Actual results:
  In second step, it will not return any data.

  In fourth step, it will return system summary data.

Expected results:
  It will return system summary data even without existing cluster.

Additional info:
  Script for testing.

  #!/bin/bash
  URL="http://USM-SERVER:8080/api/v1"
  quiet="-q -O-"
  rm -f cookies.txt
  wget ${quiet} --post-data='{"username":"admin", "password":"admin"}' --save-cookies cookies.txt ${URL}/auth/login
  wget ${quiet} --load-cookies cookies.txt -p ${URL}/system/summary

Comment 2 Daniel Horák 2016-06-24 11:32:24 UTC
Testerd and VERIFIED on:
  ceph-ansible-1.0.5-22.el7scon.noarch
  ceph-installer-1.0.12-2.el7scon.noarch
  rhscon-ceph-0.0.26-1.el7scon.x86_64
  rhscon-core-0.0.26-1.el7scon.x86_64
  rhscon-core-selinux-0.0.26-1.el7scon.noarch
  rhscon-ui-0.0.41-1.el7scon.noarch

>> VERIFIED

Comment 4 errata-xmlrpc 2016-08-23 19:49:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.