Bug 1323659 - rpc: assign port only if it is unreserved
Summary: rpc: assign port only if it is unreserved
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1332838
TreeView+ depends on / blocked
 
Reported: 2016-04-04 11:23 UTC by Prasanna Kumar Kalever
Modified: 2016-06-16 14:03 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1332838 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:03:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-04-04 11:23:09 UTC
Description of problem:
basically we are assigning port first then checking if it is reserved

Version-Release number of selected component (if applicable):
mainline

Fix:
we get unreserved port first and then assign it

Comment 1 Vijay Bellur 2016-04-04 11:25:04 UTC
REVIEW: http://review.gluster.org/13900 (rpc: assign port only if it is unreserved) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-04-04 11:34:02 UTC
REVIEW: http://review.gluster.org/13900 (rpc: assign port only if it is unreserved) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 3 Vijay Bellur 2016-04-06 17:08:50 UTC
COMMIT: http://review.gluster.org/13900 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 7370633b6404bbd3c8238b464bc413689dcccf93
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Mon Apr 4 16:15:18 2016 +0530

    rpc: assign port only if it is unreserved
    
    Current order:
        assign port;
        check for port;
        if reserved {
            port--;
            continue to i;
        }
        bind();
    
    basically, we are assigning port first then checking if it is reserved
    
    Fix:
        get unreserved port;
        assign port;
        bind();
    
    from now, we get unreserved port first and then assign it
    
    Change-Id: I004580c5215e7c9cae3594af6405b20fcd9fa4ad
    BUG: 1323659
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/13900
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Niels de Vos 2016-06-16 14:03:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.