Bug 1323700 - upgrade-non-controller.sh --query doesn't report the upgrade status
Summary: upgrade-non-controller.sh --query doesn't report the upgrade status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Marios Andreou
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 13:07 UTC by Marius Cornea
Modified: 2016-12-29 16:57 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-common-5.2.1-0.20161007114757.cc19d04.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, in the OpenStack Director, the 'upgrade-non-controller.sh' script used by an operator on the Undercloud to upgrade the non-controller nodes as a part of the major upgrade workflow did not report the upgrade status when the '--query' option was used. As a result, the '--query' option did not work as documented by the '-h' helptext. With this update, the '--query' option now provides the last few lines of the 'yum.log' file from the given node as an indication of the upgrade status. Also, the script now accepts the long and short versions for each of the options ('-q' and '--query'). As a result, the 'upgrade-non-controller.sh' script is now improved to provide at least some indication of the node upgrade status.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:29:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 324546 None None None 2016-10-14 16:09:25 UTC

Description Marius Cornea 2016-04-04 13:07:27 UTC
Description of problem:
upgrade-non-controller.sh --query doesn't report the upgrade status

stack@instack:~>>> upgrade-non-controller.sh --query overcloud-novacompute-0
Mon Apr  4 08:59:36 EDT 2016 upgrade-non-controller.sh nova node overcloud-novacompute-0 found with status ACTIVE
stack@instack:~>>> 

We should either remove it from the script if it's not used or make it report the upgrade status. I think it's going to be handy when determining which nodes need to be evacatued/removed from nova scheduler, etc.

Version-Release number of selected component (if applicable):
openstack-tripleo-common-0.3.1-1.el7ost.noarch

Comment 2 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 3 Marios Andreou 2016-10-14 16:09:26 UTC
This was fixed in https://review.openstack.org/#/c/324546/ . It is definitely available in 10 (confirmed today on my undercloud... with openstack-tripleo-common-5.2.1-0.20160930181658.40ad7e5.el7ost.noarch )

moving to POST


so now upgrade-non-controller -q does _something_ and the helptext is more accurate:

        [stack@instack ~]$ upgrade-non-controller.sh -h
        Usage: upgrade-non-controller.sh

        Options:
          -h|--help                    -- print this help.
          -u|--upgrade <nova node>     -- nova node name or id to upgrade
          -s|--script <absolute_path>  -- absolute path to the script you wish
                                          to use for the upgrade
          -q|--query <nova node>       -- determine if the node is ACTIVE and
                                          has the upgrade script. Also, tail
                                          yum.log for any package update info

        Invoke the tripleo upgrade script on non controller nodes as part of
         the tripleo upgrade workflow.


        [stack@instack ~]$ upgrade-non-controller.sh -q overcloud-compute-0
        Fri Oct 14 12:01:22 EDT 2016 upgrade-non-controller.sh nova node overcloud-compute-0 found with status ACTIVE
        Fri Oct 14 12:01:23 EDT 2016 upgrade-non-controller.sh checking for upgrade script /root/tripleo_upgrade_node.sh on node overcloud-compute-0 (192.0.2.15)
        Fri Oct 14 12:01:23 EDT 2016 upgrade-non-controller.sh upgrade script /root/tripleo_upgrade_node.sh found on node overcloud-compute-0 (192.0.2.15)
        Fri Oct 14 12:01:24 EDT 2016 upgrade-non-controller.sh We can't remotely tell if the upgrade has run on overcloud-compute-0.
        Fri Oct 14 12:01:24 EDT 2016 upgrade-non-controller.sh We can check for package updates... trying to tail yum.log on overcloud-compute-0:
        Oct 14 11:49:04 Installed: rhos-release-1.0.72-1.noarch
        Oct 14 11:49:37 Installed: wget-1.14-13.el7.x86_64


        [stack@instack ~]$ upgrade-non-controller.sh -q overcloud-controller-0
        Fri Oct 14 12:00:57 EDT 2016 upgrade-non-controller.sh nova node overcloud-controller-0 found with status ACTIVE
        Fri Oct 14 12:00:59 EDT 2016 upgrade-non-controller.sh checking for upgrade script /root/tripleo_upgrade_node.sh on node overcloud-controller-0 (192.0.2.13)
        ls: cannot access /root/tripleo_upgrade_node.sh: No such file or directory

Comment 5 mlammon 2016-11-01 21:03:52 UTC
This looks resolved now.   This checking on a system going from 9->10

[stack@undercloud-0 ~]$ nova list
+--------------------------------------+--------------+--------+------------+-------------+---------------------+
| ID                                   | Name         | Status | Task State | Power State | Networks            |
+--------------------------------------+--------------+--------+------------+-------------+---------------------+
| d02b9cf7-eecd-4141-81a4-10836f89f409 | ceph-0       | ACTIVE | -          | Running     | ctlplane=192.0.2.7  |
| dab7c88a-7198-4060-94a7-cb82215f1176 | compute-0    | ACTIVE | -          | Running     | ctlplane=192.0.2.8  |
| 389b8223-6992-43b0-83dd-530d9ed877f7 | controller-0 | ACTIVE | -          | Running     | ctlplane=192.0.2.10 |
| f8baf21b-fbb2-46f7-89ba-5d4fa2b6a940 | controller-1 | ACTIVE | -          | Running     | ctlplane=192.0.2.9  |
| 99a608af-5ecc-46b5-9ab8-b82c72906c9c | controller-2 | ACTIVE | -          | Running     | ctlplane=192.0.2.11 |
+--------------------------------------+--------------+--------+------------+-------------+---------------------+
[stack@undercloud-0 ~]$ upgrade-non-controller.sh --query compute-0
Tue Nov  1 15:30:56 EDT 2016 upgrade-non-controller.sh nova node compute-0 found with status ACTIVE
Tue Nov  1 15:30:59 EDT 2016 upgrade-non-controller.sh checking for upgrade script /root/tripleo_upgrade_node.sh on node compute-0 (192.0.2.8)
Tue Nov  1 15:30:59 EDT 2016 upgrade-non-controller.sh upgrade script /root/tripleo_upgrade_node.sh found on node compute-0 (192.0.2.8)
Tue Nov  1 15:31:02 EDT 2016 upgrade-non-controller.sh We can't remotely tell if the upgrade has run on compute-0.
Tue Nov  1 15:31:02 EDT 2016 upgrade-non-controller.sh We can check for package updates... trying to tail yum.log on compute-0:
Nov 01 17:44:02 Updated: erlang-os_mon-18.3.4.4-1.el7ost.x86_64
Nov 01 17:44:02 Updated: erlang-eldap-18.3.4.4-1.el7ost.x86_64
Nov 01 17:44:02 Updated: erlang-xmerl-18.3.4.4-1.el7ost.x86_64
Nov 01 17:44:02 Updated: os-apply-config-5.0.0-1.el7ost.noarch
Nov 01 17:44:02 Updated: memcached-1.4.25-1.el7ost.x86_64
Nov 01 17:44:02 Updated: python-jsonpointer-1.10-4.1.el7ost.noarch
Nov 01 17:44:02 Updated: openstack-utils-2016.1-1.el7ost.noarch
Nov 01 17:44:24 Erased: openstack-swift-2.7.0-2.el7ost.noarch
Nov 01 17:44:26 Erased: python-pyasn1-modules-0.1.9-1.el7ost.noarch
Nov 01 17:44:27 Erased: 1:ceph-0.94.9-3.el7cp.x86_64


[stack@undercloud-0 ~]$ rpm -qa | grep openstack-tripleo-common
openstack-tripleo-common-5.3.0-3.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 15:29:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.