Bug 1323715 - Synchronizing RHEL 5 repos fail with Field is required: ['variant']
Summary: Synchronizing RHEL 5 repos fail with Field is required: ['variant']
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 13:36 UTC by Og Maciel
Modified: 2019-09-25 21:29 UTC (History)
11 users (show)

Fixed In Version: pulp-rpm-plugins-2.8.1.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:30:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
[Verified] Screenshot Attached (118.04 KB, image/png)
2016-04-18 11:09 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Pulp Redmine 1768 High CLOSED - CURRENTRELEASE Unable to sync RHEL 5 repositories with a distribution 2016-05-17 20:01:30 UTC

Description Og Maciel 2016-04-04 13:36:25 UTC
Description of problem:

Basically, I am getting the following error when syncing RHEL 5 RPMs (other versions of RHEL work fine):

    uninitialized constant Actions::Pulp::AbstractAsyncTask::PulpError

The repositories are:

* Red Hat Enterprise Linux 5 Server Kickstart i386 5.11
* Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11

This caught my attention:

    Field is required: ['variant']

Version-Release number of selected component (if applicable):

* Satellite 6.2.0 SNAP 6.1

How reproducible:


Steps to Reproduce:
1. Enable RHEL 5 RPM repositories
2. Synchronize them from the UI
3.

Actual results:

The sync process fails

Expected results:


Additional info:


Logs (/v/l/messages) show:

Apr  4 09:23:58 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cdn.redhat.com
Apr  4 09:23:59 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Parsing metadata.
Apr  4 09:23:59 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata files.
Apr  4 09:23:59 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (2): cdn.redhat.com
Apr  4 09:23:59 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (3): cdn.redhat.com
Apr  4 09:24:00 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Generating metadata databases.
Apr  4 09:24:13 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Determining which units need to be downloaded.
Apr  4 09:24:42 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.purge:INFO: Removing missing units.
Apr  4 09:24:51 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading additional units.
Apr  4 09:24:51 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cdn.redhat.com
Apr  4 09:24:52 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cdn.redhat.com
Apr  4 09:24:53 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cdn.redhat.com
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832) ValidationError (Distribution:48ae9e55-ce23-4188-9002-edcd402e1ec4) (Field is required: ['variant'])
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832) Traceback (most recent call last):
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 228, in run
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)     dist_sync.run()
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/parse/treeinfo.py", line 125, in run
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)     self._run(tmp_dir)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/parse/treeinfo.py", line 179, in _run
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)     unit.save()
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)   File "/usr/lib/python2.7/site-packages/mongoengine/document.py", line 304, in save
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)     self.validate(clean=clean)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)   File "/usr/lib/python2.7/site-packages/mongoengine/base/document.py", line 413, in validate
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832)     raise ValidationError(message, errors=errors)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (11630-68832) ValidationError: ValidationError (Distribution:48ae9e55-ce23-4188-9002-edcd402e1ec4) (Field is required: ['variant'])
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp.server.event.http:INFO: (11630-68832) {"call_report": {"exception": null, "task_type": "pulp.server.managers.repo.sync.sync", "_href": "/pulp/api/v2/tasks/ceb760ea-82bd-4bf1-8797-7f407e3feeaa/", "task_id": "ceb760ea-82bd-4bf1-8797-7f407e3feeaa", "tags": ["pulp:repository:Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_Kickstart_i386_5_11", "pulp:action:sync"], "finish_time": null, "_ns": "task_status", "start_time": "2016-04-04T13:23:56Z", "traceback": null, "spawned_tasks": [], "progress_report": {"yum_importer": {"content": {"items_total": 0, "state": "FINISHED", "error_details": [], "details": {"rpm_total": 0, "rpm_done": 0, "drpm_total": 0, "drpm_done": 0}, "size_total": 0, "size_left": 0, "items_left": 0}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"items_total": 0, "state": "FAILED", "error_details": [], "items_left": 0, "error": "ValidationError (Distribution:48ae9e55-ce23-4188-9002-edcd402e1ec4) (Field is required: ['variant'])"}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}}, "state": "running", "worker_name": "reserved_resource_worker-2@ibm-x3250m4-01.lab.eng.rdu2.redhat.com", "result": null, "error": null, "_id": {"$oid": "57026aebe7056a4316df9e3e"}, "id": "57026aebe7056a4316df9e3e"}, "event_type": "repo.sync.finish", "payload": {"importer_id": "yum_importer", "exception": null, "repo_id": "Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_Kickstart_i386_5_11", "traceback": null, "started": "2016-04-04T13:23:56Z", "_ns": "repo_sync_results", "completed": "2016-04-04T13:24:54Z", "importer_type_id": "yum_importer", "error_message": null, "summary": {"content": {"state": "FINISHED"}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"state": "FAILED"}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}, "added_count": 0, "result": "failed", "updated_count": 2549, "de
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp.server.event.http:INFO: (11630-68832) tails": {"content": {"size_total": 0, "items_left": 0, "items_total": 0, "state": "FINISHED", "size_left": 0, "details": {"rpm_total": 0, "rpm_done": 0, "drpm_total": 0, "drpm_done": 0}, "error_details": []}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"items_total": 0, "state": "FAILED", "error_details": [], "items_left": 0, "error": "ValidationError (Distribution:48ae9e55-ce23-4188-9002-edcd402e1ec4) (Field is required: ['variant'])"}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}, "id": "57026b264a45522d6ed98bd1", "removed_count": 0}}
Apr  4 09:24:54 ibm-x3250m4-01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): ibm-x3250m4-01.lab.eng.rdu2.redhat.com
Apr  4 09:24:54 ibm-x3250m4-01 pulp: pulp.server.async.tasks:INFO: Task failed : [ceb760ea-82bd-4bf1-8797-7f407e3feeaa]
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832) Task pulp.server.managers.repo.sync.sync[ceb760ea-82bd-4bf1-8797-7f407e3feeaa] raised unexpected: PulpExecutionException('Importer indicated a failed response',)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832) Traceback (most recent call last):
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)     R = retval = fun(*args, **kwargs)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 473, in __call__
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)     return super(Task, self).__call__(*args, **kwargs)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)     return super(PulpTask, self).__call__(*args, **kwargs)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)     return self.run(*args, **kwargs)
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 810, in sync
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832)     raise pulp_exceptions.PulpExecutionException(_('Importer indicated a failed response'))
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:ERROR: (11392-68832) PulpExecutionException: Importer indicated a failed response
Apr  4 09:24:54 ibm-x3250m4-01 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[b63e6fd9-934f-47dd-bbe0-011a5e9b2156] succeeded in 0.00471513101365s: None

Comment 2 pulp-infra@redhat.com 2016-04-04 16:03:53 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 3 pulp-infra@redhat.com 2016-04-04 16:03:55 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2016-04-07 13:03:42 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2016-04-07 15:42:58 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2016-04-11 18:33:51 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 8 Jitendra Yejare 2016-04-18 11:09:48 UTC
Created attachment 1148173 [details]
[Verified] Screenshot Attached

Comment 9 Jitendra Yejare 2016-04-18 11:10:05 UTC
Verified this issue in Sat 6.2 snap 8.2

I am able to sync 'Red Hat Enterprise Linux 5 Server Kickstart i386 5.11' and 'Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11' successfully.

Screenshot Attached.

Moving this issue to verified.

Comment 10 pulp-infra@redhat.com 2016-04-26 23:04:29 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-05-05 13:30:50 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 12 pulp-infra@redhat.com 2016-05-17 20:01:31 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 14 errata-xmlrpc 2016-07-27 09:30:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.