Bug 1323774 - deploy fails, yet continues in background, can't successfully 'heat stack-delete' overcloud
Summary: deploy fails, yet continues in background, can't successfully 'heat stack-del...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 7.0 (Kilo)
Hardware: All
OS: All
medium
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 16:24 UTC by Dan Yocum
Modified: 2016-12-14 15:31 UTC (History)
10 users (show)

Fixed In Version: python-tripleoclient-5.3.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:31:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Dan Yocum 2016-04-04 16:24:53 UTC
Description of problem:

When performing a openstack deploy overcloud after about 35 minutes, the deploy fails, but continues in the background. 

Attempting to run 'heat stack-delete <uuid>' works on some stacks but not others.  Running "watch -n5 'nova list; ironic node-list'" I observe the control nodes attempt to launch, fail, delete, then get launched again, fail, delete, etc. etc.

Running 'heat stack-delete' finally deletes the overcloud.

Version-Release number of selected component (if applicable):

OSP-d 7.3

python-rdomanager-oscplugin-0.0.10-28.el7ost.noarch


How reproducible:

every time, so far.

Comment 2 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 3 James Slagle 2016-10-14 15:33:20 UTC
please retest and confirm if this still an issue or not

Comment 7 Marius Cornea 2016-11-22 18:48:23 UTC
I wasn't able to reproduce the issue in the initial report, moving this one to verified.

Comment 9 errata-xmlrpc 2016-12-14 15:31:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.