Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1323793 - Unable to login via the Red Hat Access module
Unable to login via the Red Hat Access module
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity urgent (vote)
: Beta
: Unused
Assigned To: Lindani Phiri
jcallaha
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-04 14:00 EDT by jcallaha
Modified: 2016-07-27 05:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: tfm-rubygem-foreman-redhat_access-1.0.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error screenshot (197.27 KB, image/png)
2016-04-04 14:00 EDT, jcallaha
no flags Details
production.log (114.28 KB, text/plain)
2016-04-05 13:23 EDT, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 08:28:58 EDT

  None (edit)
Description jcallaha 2016-04-04 14:00:46 EDT
Created attachment 1143406 [details]
Error screenshot

Description of problem:
While attempting to log in via the RH Access module, I am told that the login failed. The Chrome console then shows a 500 error after the request.

Version-Release number of selected component (if applicable):
Satellite 6.1 Beta Snap 6 Compose 1

How reproducible:
Always

Steps to Reproduce:
1. Attempt to log in to Red Hat Access via the UI module with the same name.
2. View results.

Actual results:
Login failed with proper credentials. 500 error seen in web console.

Expected results:
Login succeeds with proper credentials. No errors seen.
Comment 2 Lindani Phiri 2016-04-05 12:45:53 EDT
@jcallaha,

Can you provide the server side logs  (/var/log/foreman/production.log?) with the exception trace?

Thanks!
Comment 3 jcallaha 2016-04-05 13:23 EDT
Created attachment 1143902 [details]
production.log
Comment 4 Lindani Phiri 2016-04-05 16:25:12 EDT
Bug is caused by changes to http proxy settings handling in 6.2.
I will impact both the Insights and Red Hat Access search/case management when an http proxy is configured for the Satellite server.
Comment 8 jcallaha 2016-04-14 10:50:27 EDT
Verified in Satellite 6.2 Beta Snap 8 compose 1.

The module now works as expected.
Comment 10 errata-xmlrpc 2016-07-27 05:30:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.