Bug 13238 - eepro driver broken
Summary: eepro driver broken
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-29 21:22 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 03:18:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-06-29 21:22:24 UTC
Hi,

With the kernel in beta2, my eepro soundcard consistently stops sending and
/ or receiving any data, this seem to happen at random moments, but can
always be reproduced by copying large files over nfs.

When it happen I get a lot of:
eth0: XMT status = 0x0
or
eth0: XMT status = 0x1
messages

Regards,

Hans

Comment 1 Hans de Goede 2000-06-29 21:22:59 UTC
Ehm make that eepro network card, duh.


Comment 2 Hans de Goede 2000-06-30 07:22:20 UTC
This NIC has worked flawlessly for me as my main nic since the 2.0
kernel days, this is the first time it breaks for me.

The only problem it has is that its bnc connecter has been kicked
against once, so sometimes (say once a month) it doesn't make electrical
contact and you have to remove and insert the cabel again. Due to this
it also has slightly more frame errors then you would normally expect. I
guess that this is what bites with the new kernel, something
probably busted the error handling.



Comment 3 Glen Foster 2000-07-18 19:52:49 UTC
This defect is considered MUST-FIX for Winston Beta-5

Comment 4 Hans de Goede 2000-07-19 06:26:43 UTC
Hint:

This is a known generic 2.2.16 kernel issue, get Alan to send you just the
2.2.17 patches for this, or maybe some more since 2.2.17 is supposed to be
overall better then 2.2.16.


Comment 5 Erik Troan 2000-07-21 16:54:10 UTC
Alan, can you help here?

Comment 6 Glen Foster 2000-07-21 18:08:29 UTC
This defect has been re-classified as MUST-FIX for Winston Gold-release

Comment 7 Michael K. Johnson 2000-08-01 21:46:14 UTC
Alan, should I suck the eepro.c changes from 2.2.17pre14 into our
current kernel?

Comment 8 Alan Cox 2000-08-01 22:00:56 UTC
As I understand from acme - yes


Comment 9 Michael K. Johnson 2000-08-03 16:24:01 UTC
Aha!  Those changes have been there since July 4 under
the guise of linux-2.2.16-sparc-eepro.patch

So this should be fixed in Pinstripe.  I'm therefore
marking this closed; reopen it if Pinstripe does not
fix this bug.

Comment 10 Hans de Goede 2000-08-11 19:43:30 UTC
Just tried it with RC1, still no go. Are you sure this patches aren't surrounded
by if($arch == sparc) in the spec file?




Comment 11 Hans de Goede 2000-08-11 19:51:14 UTC
p.s.

How about going back to eepro from the kernel with 6.2, that had some bugs too
(like hanging the machine if you insmod it without an io parameter and your card
is not at the default adres) but atleast it worked.

Alan I can miss this card, I usually just use it to torture kernels since it is
such a "great" card. so if you want it to test the eepro driver, send me a
private mail with your address and stuff.


Comment 12 Erik Troan 2000-08-16 16:53:03 UTC
Is this failing in the install or after the install?

Comment 13 Michael K. Johnson 2000-08-17 18:43:41 UTC
Yes, the patch is applied on all arch's in our spec file.
Also, while part of the patch is ifdef __sparc__, it is
the same in our sparc-eepro patch and in Alan's patch.

Comment 14 Michael K. Johnson 2000-08-17 18:53:35 UTC
Erm, I the sparc-eepro patch is against the eepro100 driver.
I'll go look again at 2.2.17-pre<latest>...

Comment 15 Michael K. Johnson 2000-08-17 19:06:07 UTC
OK, 2.2.16-21.3 and later will include this fix to the driver.
Sorry for the confusion!

Comment 16 Hans de Goede 2000-08-21 09:41:53 UTC
Verified, works fine now.


Comment 17 Ben LaHaise 2000-08-31 21:46:24 UTC
The eepro100 driver in 2.2.16-22 does not work on an 82559 based card here; it
spews card reports no resources/no RX buffers about once per second.

Comment 18 Michael K. Johnson 2000-08-31 22:14:33 UTC
OK, Ben, send me a patch!  :-)

Try the e100 driver and see if it works; that's useful info.

Comment 19 Glen Foster 2001-01-11 21:02:45 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 20 Michael K. Johnson 2001-01-12 14:38:34 UTC
Ben, this bug report was about the eepro, not eepro100.  Since it
was fixed for eepro, I'm closing this.  If eepro100 is still broken
with that card with the 2.4 kernel, please open a new bug report
against that kernel or simply fix it...  :-)

Comment 21 Alan Cox 2001-01-12 14:55:57 UTC
Eepro is broken in 2.4.0. It might be fixed in -ac now but Im not sure


Comment 22 Brent Fox 2001-04-06 15:30:40 UTC
The eepro100 driver is working fine on my test machine with the 2.4.2-x kernels.
 Can we consider this issue resolved?

Comment 23 Arjan van de Ven 2001-04-08 00:38:30 UTC
bfox: no, this is not about eepro100!  It's about the 10mbit eepro driver.

Comment 24 Hans de Goede 2001-04-08 14:17:20 UTC
Tihs bug was about an eepro10 (isa) but I'm not sure anymore what it is about
right now, I guess it can be closed when both the eepro10 (isa) and the eepro100
(pci) work.



Note You need to log in before you can comment on or make changes to this bug.