This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 132385 - /etc/localtime is configured too late during install
/etc/localtime is configured too late during install
Status: CLOSED DUPLICATE of bug 106572
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-11 22:16 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-09-11 22:16:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
bind-chroot copies /etc/localtime to /var/named/chroot/etc/localtime.
 Oddly, even though I select America/Sao_Paulo as the timezone early
in the install, the file copied by bind-chroot's %post script is the
America/New_York localtime file.  The timestamp of /etc/localtime
shows it was only set up for the timezone I selected at the end of the
install.  This means that any chroot packages that copy /etc/localtime
will get it wrong.  Would it be possible to get anaconda (or glibc?)
to install this file with the selected timezone earlier?

Version-Release number of selected component (if applicable):
anaconda-10.0.2-3

How reproducible:
Always

Steps to Reproduce:
1.Select a timezone other than America/New_York in the installer
2.Perform a full everything install (or at least something that
installs bind-chroot)
3.After the install is complete, compare /etc/localtime with
/var/named/chroot/etc/localtime

Actual Results:  They're different.  The latter is America/New_York,
while the former is whatever you selected.

Expected Results:  They're supposed to be the same.

Additional info:

This is related with bug 106572.
Comment 1 Jason Vas Dias 2004-09-13 11:09:07 EDT
It would be great if we could make /var/named/chroot/etc/localtime
a link to /etc/localtime; but if it is a symbolic link, it will not
work during chroot, and if it is a hard link, this will not work if
/var is on a separate partition to / .
I can change the named initscript to check if /etc/localtime is 
identical to /var/named/chroot/etc/localtime and copy it again
if not; that might be simpler than fixing it in anaconda.
Comment 2 Jeremy Katz 2004-09-13 11:28:36 EDT
I can't write /etc/localtime earlier because the source file doesn't
exist until after packages are put on the system.  The packaging needs
to be fixed.
Comment 3 Jason Vas Dias 2004-09-13 11:35:09 EDT
 I'll fix this in BIND as described in comment #1 above.
Comment 4 Alexandre Oliva 2004-09-13 17:00:06 EDT

*** This bug has been marked as a duplicate of 106572 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.