Bug 1323922 - [wayland][gtk3] paste from primary selection does not work when primary selection was done in a different app
Summary: [wayland][gtk3] paste from primary selection does not work when primary selec...
Keywords:
Status: CLOSED DUPLICATE of bug 1326304
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-05 05:35 UTC by Thorsten Leemhuis
Modified: 2016-06-27 06:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-27 06:31:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Thorsten Leemhuis 2016-04-05 05:35:36 UTC
Description of problem:
I'm running a Gnome wayland session and in libreoffice most of the time can't paste anything from the clipboard that was put there by some other app (it works for texts that I put into the clipboard using libreoffice). Exactly the same for a middle mouse-click paste. It works just fine after uninstalling libreoffice-gtk3.

Version-Release number of selected component (if applicable):
libreoffice-5.1.2.1-3.fc24.x86_64

Comment 1 Thorsten Leemhuis 2016-04-11 12:50:07 UTC
Paste from clipboard started working with libreoffice-5.1.2.1-4.fc24.x86_64; paste from primary selection still does not work properly: it only works within libreoffice, not when I select a text in a different app.

Comment 2 Caolan McNamara 2016-04-11 14:41:32 UTC
There were no changes from 5.1.2.1-3 to 5.1.2.1-4 which would explain a change in behaviour. Perhaps gtk3 itself was upgraded also and brought along the desirable CLIPBOARD change.

Last time I looked at this closely wayland didn't support PRIMARY, but there were plans to add it (https://lists.freedesktop.org/archives/wayland-devel/2015-December/026084.html) which appear to be integrated into F24 (https://fedoraproject.org/wiki/Wayland_features#BLOCKER:_primary_selection)

The gtk3 PRIMARY works under X (presumably) and *presumably* other gtk3 apps are working fine with PRIMARY under wayland now ?

Comment 3 Thorsten Leemhuis 2016-04-12 06:37:50 UTC
(In reply to Caolan McNamara from comment #2)
> There were no changes from 5.1.2.1-3 to 5.1.2.1-4 which would explain a
> change in behaviour. Perhaps gtk3 itself was upgraded also and brought along
> the desirable CLIPBOARD change.

FWIW & jus for the protocol: I didn't get a gtk3 update between reporting this bug and by comment yesterday that it started working. Must be something else then (or a combination of a odd bug with a layer 8 problem or something like that; whatever)

> The gtk3 PRIMARY works under X (presumably) and *presumably* other gtk3 apps
> are working fine with PRIMARY under wayland now ?

Yeah, pasting the primary selection works in f24 nearly everywhere afaics: from Xwayland clients like firefox to wayland clients and vice versa; also from Xwayland to Xwayland client and wayland to wayland client. It even works partly with libreoffice when libreoffice-gtk3 is installed and running as a wayland client, as I can select something there and paste it there using a middle click; I can also paste a libreoffice section in other apps. But I can't paste a selection from Xwayland or wayland clients into a libreoffice document.

Comment 4 Thorsten Leemhuis 2016-04-12 08:45:11 UTC
(In reply to Thorsten Leemhuis from comment #3)
> FWIW & just for the protocol: I didn't get a gtk3 update between reporting
> this bug and by comment yesterday that it started working. Must be something
> else then (or a combination of a odd bug with a layer 8 problem or something
> like that; whatever)
Just for the protocol again: Stardict was the culprit. I should get rid of it...

Anyway: Selecting a text in some app and paste it by a middle click in libreoffice still does not work.

Comment 5 Thorsten Leemhuis 2016-04-12 11:33:54 UTC
(In reply to Thorsten Leemhuis from comment #4)
> (In reply to Thorsten Leemhuis from comment #3)
> > FWIW & just for the protocol: I didn't get a gtk3 update between reporting
> > this bug and by comment yesterday that it started working. Must be something
> > else then (or a combination of a odd bug with a layer 8 problem or something
> > like that; whatever)
> Just for the protocol again: Stardict was the culprit. I should get rid of
> it...

Strike that: Turns out is has nothing to do with stardict, as proper clipboard pasting stops to work for other reasons. Reported them in Bug 1326304, as it seems to me that particular problem has nothing to do with the problem when trying to paste from primary selection.

Comment 6 Thorsten Leemhuis 2016-06-27 06:31:47 UTC
Fixed by the changes mention in another bug, so in the end it was just one problem afaics

*** This bug has been marked as a duplicate of bug 1326304 ***


Note You need to log in before you can comment on or make changes to this bug.