Bug 132393 - error in init.d/pcmcia prevent PCMCIA socket driver loading
Summary: error in init.d/pcmcia prevent PCMCIA socket driver loading
Status: CLOSED DUPLICATE of bug 121742
Alias: None
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-12 10:25 UTC by Francois-Xavier 'FiX' KOWALSKI
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for pcmcia-cs shipped with fc1 (1.08 KB, patch)
2004-09-12 10:28 UTC, Francois-Xavier 'FiX' KOWALSKI
no flags Details | Diff

Description Francois-Xavier 'FiX' KOWALSKI 2004-09-12 10:25:25 UTC
Description of problem:

my HP ob900 laptop works with the PCMCIA socket driver yenta_socket. 
this driver was successfully probed by anaconda & is declared as such
in /etc/sysconfig/pcmcia as $PCIC.

however, at boot time, /etc/init.d/pcmcia does not even attempt to
load it.  as a result, no PCMCIA-based service can work.  this
includes -- for me -- my xircom network driver.

work-around is after boot, run the following:

1. modprobe yenta_socket
2. service pcmcia restart
3. ifup eth0 (all the network dependent services are restart by my
customized dhclient-hooks script)

Version-Release number of selected component (if applicable):

pcmcia-cs-3.1.31-13

How reproducible:

always

Steps to Reproduce:
1. reboot the box
2.
3.
  
Actual results:

yenta_socket is not loaded so I have access to my PCMCIA cards


Expected results:

I should have access to my PCMCIA cards


Additional info:

Comment 1 Francois-Xavier 'FiX' KOWALSKI 2004-09-12 10:28:38 UTC
Created attachment 103760 [details]
patch for pcmcia-cs shipped with fc1

I have tried to make this patch as clean as possible: it does not only apply to
my personnal case...

Comment 2 Francois-Xavier 'FiX' KOWALSKI 2004-09-12 10:33:59 UTC
also see the same bug -- also with a patch -- on fc2 #132394
<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=132394>

Comment 3 Bill Nottingham 2004-09-13 17:35:04 UTC

*** This bug has been marked as a duplicate of 121742 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:05:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.