Bug 132396 - "Latin" unit LE in gimlet despite Removed
Summary: "Latin" unit LE in gimlet despite Removed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: IIIMF FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-09-12 11:53 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-05-23 07:08:37 UTC


Attachments (Terms of Use)

Description Warren Togami 2004-09-12 11:53:55 UTC
Description of problem:
When running htt_server within valgrind for debugging purposes, unit
LE takes over gimlet in annoying ways even if it is not "Added".  This
does not seem to be an issue when running htt_server normally on i386,
but I suspect this is one of the several ways in which valgrind is
exposing a memory usage problem that bite us on other architectures.

Version-Release number of selected component (if applicable):
im-sdk-12.0.1-6.svn1891

How reproducible:
Always

Steps to Reproduce:
1. Install all LE's.
2. Be sure that unit is removed from the active LE's.
3. service iiim stop
4. valgrind --log-file=htt_server --tool=memcheck --leak-check=yes
htt_server -d
5. Hit hotkey activator within any application. 
    

Actual Results:
gimlet says "Latin".  When you left-click on gimlet, Latin(C) is
listed, with right arrow option "unitle".

Expected Results:
"Latin" should not even be in the menu.

Comment 1 Warren Togami 2004-09-12 12:04:20 UTC
i386 MALLOC_CHECK_=3 htt_server -d exhibits similar bad behavior with
unitle.

Comment 2 Warren Togami 2004-09-13 00:39:44 UTC
Hmm, I'm not exactly sure why, but this problem seems to exhibit
itself when not running htt_server within valgrind too.  mmm...

Comment 3 Jens Petersen 2004-09-30 03:54:44 UTC
Do you think see this with the latest builds?

Comment 4 Lawrence Lim 2004-09-30 06:57:50 UTC
Tested with im-sdk-12.0.1-9.svn1936 and Latin still shows after all LE
including Latin is removed. Please let me know if you require a
screenshot.

Comment 5 Jens Petersen 2004-10-05 02:56:51 UTC
Warren, this is with en_US.UTF-8?

Comment 6 Warren Togami 2004-10-25 14:57:23 UTC
Yes.

Comment 7 Jens Petersen 2005-05-16 14:41:20 UTC
I can't reproduce this with iiimf-12.2 anyway.

Comment 8 Lawrence Lim 2005-05-23 06:26:18 UTC
I still can reproduce this bug with iiimf-12.2-3.

Steps to reproduce:
1. install 'everything' of iiimf-12.2-3
2. start gnome-terminal
3. remove all LE in GIMLET
4. in gnome-terminal, service iiim restart
5. ctrl-space

Actual Result:
Latin is activated

Expected Result:
Nothing or LE for my locale (zh_TW) activated



Comment 9 Lawrence Lim 2005-05-23 07:08:37 UTC
After reading through again, noticed that this bug has been fixed. GIMLET is not
empty when all LE has been removed. Will createa new bug for Comment #8.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.