Bug 132397 - Breakage in new ImageMagick RPM (workaround provided)
Breakage in new ImageMagick RPM (workaround provided)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-12 08:03 EDT by Reuben Farrelly
Modified: 2013-04-02 00:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: 6.0.7.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 08:13:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-09-12 08:03:31 EDT
The new ImageMagick RPM has some breakage which the previous 5.5 
version did not have.  On running an application on my web server now 
I get this logged:

[Sun Sep 12 14:35:20 2004] [error] [client 192.168.0.6] [Sun Sep 12 
14:35:20 2004] index.cgi: Exception 495: UnableToOpenConfigureFile 
at ./imagemagick.pl line 27., referer: http://.. 

Some debugging shows this:

[root@tornado ~]# convert -debug configure logo: image.pnm
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/lib/ImageMagick-
6.0.6/config/delegates.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/share/ImageMagick-
6.0.6/config/delegates.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/share/ImageMagick-
6.0.6/delegates.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/root/.magick/delegates.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "delegates.mgk"
23:54:45 0:01 0.020u convert[21047]: 
delegate.c/LoadDelegateList/1094/Configure
  Loading delegate file "/usr/lib/ImageMagick-
6.0.6/config/delegates.mgk" ...
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/lib/ImageMagick-
6.0.6/config/magic.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/share/ImageMagick-
6.0.6/config/magic.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/usr/share/ImageMagick-
6.0.6/magic.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "/root/.magick/magic.mgk"
23:54:45 0:01 0.020u convert[21047]: 
configure.c/GetConfigureOptions/491/Configure
  Searching for configure file: "magic.mgk"
23:54:45 0:01 0.020u convert[21047]: 
magic.c/LoadMagicList/683/Configure
  Loading magic file "built-in" ...
convert: UnableToOpenConfigureFile.
convert: missing an image filename `image.pnm'.
[root@tornado ~]# 

Ignoring the invalid file name, note that ImageMagick is looking in 
the wrong place for the magic.mgk file which is located in:

[root@tornado up2date]# locate magic.mgk
/usr/share/ImageMagick/magic.mgk
[root@tornado up2date]

It never finds this config file, and aborts with an error.

So, either the magic.mgk file needs to be placed in the path where 
ImageMagick (convert) can find it, or else the path names need to be 
modified.

I moved the magic.mgk file on my system to /usr/lib/ImageMagick-
6.0.6/config/ and the bug was succesfully worked around.


As an aside from this, there appears to be a lot of unnecessary 
duplication of ALL the config files between /usr/share/ImageMagick/ 
and /usr/lib/ImageMagick-6.0.6/config/
Comment 1 Karsten Hopp 2004-09-13 17:44:53 EDT
There is already an ImageMagick-6.0.7-1 package in the queue which  
fixes the same configfile problem with display instead of convert for 
me. I'll leave this report open for the duplicate config files. 
Comment 2 Alexandre Oliva 2004-09-15 14:04:45 EDT
I don't see it in rawhide yet.  Should it be there yet?  It would be
nice to ship FC3test2 without a totally unusable ImageMagick (AFAICT
there's nothing I can do with it).
Comment 3 Karsten Hopp 2004-09-15 14:50:48 EDT
Looks like it will make it into FC3test2, it just got moved to the 
FC3 trees. 
I had to fix the config stuff too as it broke OO builds. Please 
verify and close this report if everything looks ok. 
Comment 5 Reuben Farrelly 2004-09-23 08:13:27 EDT
Yep, all works fine now.  Thanks for fixing, closing now.....

Note You need to log in before you can comment on or make changes to this bug.