Bug 132403 - gnucash fails to start, gives gconf error
gnucash fails to start, gives gconf error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: GConf (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-12 14:21 EDT by Chris Swiedler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 12:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Swiedler 2004-09-12 14:21:55 EDT
Description of problem:

gnucash is failing to start. I ran it successfully for a few days, but
now it fails at startup with the text:




Version-Release number of selected component (if applicable):

Looking in Installed Packages:
Name   : GConf
Arch   : i386
Version: 1.0.9
Release: 13.1


How reproducible:

Unknown.

Steps to Reproduce:
1. start gnucash
2.
3.
  
Actual results:

gnucash fails to start with error message on console.

Expected results:

gnucash should start properly.

Additional info:

gtkhtml-ERROR **: gconf error: Configuration server couldn't be contacted:
 Adding client to server's list failed, CORBA error:
IDL:omg.org/CORBA/COMM_FAILURE:1.0

I have looked into mailing list messages from Havoc like
"http://mail.gnome.org/archives/gnome-list/2002-February/msg00170.html". 

gconf-sanity-check-1 produces:
Please contact your system administrator to resolve the following problem:
Failed to get a file lock: Failed to lock
'/home/chris/.gconfd/lock/ior': probably another process has the lock,
or your operating system has NFS file locking misconfigured, or a hard
NFS client crash caused a stale lock (Resource temporarily
unavailable) - run gconf-sanity-check-1 for possible diagnosis, see
http://www.gnome.org/projects/gconf/ for more information

When I run gconf-sanity-check-1, gconfd-2 is running.  My home
directory is NFS-mounted from a Debian Sarge box. lockd, rpciod are
running on the NFS server. rpc.statd, rpc.idmapd, rpciod, and lockd
are running on the Fedora NFS client.
Comment 1 Mark McLoughlin 2004-09-24 12:55:54 EDT
does gconftool-2 -R /apps/metacity work ?

I presume not - this sounds like a problem with the NFS configuration,
just like the warning message suggests. I don't really have any advice
on how to fix that, you could try one of the fedora mailing lists to
see if anyone else has had success, but it doesn't appear to be a
GConf bug. 

Thanks, closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.