Bug 1324040 - marker: set inode ctx before lokkup is unwind
Summary: marker: set inode ctx before lokkup is unwind
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1318170
Blocks: 1299184 1318093 1320925 1320926
TreeView+ depends on / blocked
 
Reported: 2016-04-05 12:02 UTC by Vijaikumar Mallikarjuna
Modified: 2019-12-16 05:36 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 1318170
Environment:
Last Closed: 2016-04-19 07:13:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-05 12:03:23 UTC
REVIEW: http://review.gluster.org/13907 (marker: build_ancestry in marker) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-04-05 12:08:27 UTC
REVIEW: http://review.gluster.org/13908 (marker: optimize mq_update_dirty_inode_task) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-05 12:21:10 UTC
REVIEW: http://review.gluster.org/13910 (marker: do mq_reduce_parent_size_txn in FG for unlink & rmdir) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2016-04-06 08:24:08 UTC
COMMIT: http://review.gluster.org/13907 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 45ea3bce3068fa2c846e8c11e069fff9eacf8532
Author: vmallika <vmallika@redhat.com>
Date:   Wed Mar 30 20:16:32 2016 +0530

    marker: build_ancestry in marker
    
    This is a backport of http://review.gluster.org/#/c/13857/
    
    * quota-enforcer doesn't execute build_ancestry in the below
      code path
        1) Special client (PID < 0)
        2) unlink
        3) rename within the same directory
        4) link within the same directory
    
        In these cases, marker accounting can fail as parent not found.
        We need to build_ancestry in marker if it doesn't find parent
        during update txn
    
    > Change-Id: Idb7a2906500647baa6d183ba859b15e34769029c
    > BUG: 1320818
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Ib56a556bdeebcc498d59599baf4655be05d765e5
    BUG: 1324040
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13907
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Vijay Bellur 2016-04-06 08:43:51 UTC
REVIEW: http://review.gluster.org/13910 (marker: do mq_reduce_parent_size_txn in FG for unlink & rmdir) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Vijay Bellur 2016-04-06 12:24:23 UTC
COMMIT: http://review.gluster.org/13908 committed in release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit 4fb5a2af7b9fe926782ea6139349eeb63be86920
Author: vmallika <vmallika@redhat.com>
Date:   Sat Apr 2 08:57:00 2016 +0530

    marker: optimize mq_update_dirty_inode_task
    
    This is a backport of http://review.gluster.org/#/c/13892/
    
    In function mq_update_dirty_inode_task we do readdirp
    on a dirty directory and for entry we again do
    lookup to fecth the contribution xattr.
    We can fetch this contribution as part of readdirp
    
    > Change-Id: I766593c0dba793f1ab3b43625acce1c7d9af8d7f
    > BUG: 1320818
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Id826a09a72529f7435372ea7f04068dd10da5fcb
    BUG: 1324040
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13908
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 7 Vijay Bellur 2016-04-06 14:08:57 UTC
COMMIT: http://review.gluster.org/13910 committed in release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit 9756226b4dfd0e4346e9c5c2f94c3a59a6254f34
Author: vmallika <vmallika@redhat.com>
Date:   Wed Apr 6 14:09:50 2016 +0530

    marker: do mq_reduce_parent_size_txn in FG for unlink & rmdir
    
    This is a backport of http://review.gluster.org/#/c/13874/
    
    * If a "rm -rf" is performed by a client, we initiate a
      marker background operation mq_reduce_parent_size_txn
      for rmdir and unlink.
    
      mq_reduce_parent_size_txn can fail when updating
      size on the ancestor directories, if these directories
      are removed during the txn as the child-parent association
      removed in the dentry list.
    
      So execute mq_reduce_parent_size_txn in foreground
      and then do the UNWIND for rmdir and unlink FOP
    
    > Change-Id: Iefcdced4c6ae0dbd43f92814d0ddcd1e33825864
    > BUG: 1322489
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I79e4b53e4bacd39d23dad5278a7d02a338e59195
    BUG: 1324040
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13910
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 10 Kaushal 2016-04-19 07:13:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.