Bug 132411 - authconfig has bad build dependencies
authconfig has bad build dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Brian Brock
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-12 16:30 EDT by Steve Grubb
Modified: 2013-07-02 19:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.6.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 03:55:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix requirements (906 bytes, patch)
2004-09-12 16:31 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2004-09-12 16:30:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The build requires needs to have perl-XML-Parser instead of the
requires. At the end of the build, it should automatically pull in the
perl-XML-Parser requirement because it was used in the build. You can
check with rpmquery -qp --requires 

Also, the requires usermode is NOT a general requirement. It is only
for  the GUI part. The console part does not need it and in fact this
requires messes up console installations.

I will attach a patch.

Version-Release number of selected component (if applicable):
authconfig-4.6.4-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -e perl-XML-Parser
2. rpmbuild -bb authconfig.spec

Additional info:
Comment 1 Steve Grubb 2004-09-12 16:31:25 EDT
Created attachment 103771 [details]
Patch to fix requirements

Please apply.
Comment 2 Jindrich Novy 2004-09-14 03:55:01 EDT
Hello Steve, I applied it and rebuilt authconfig. authconfig-4.6.4-3
is now available with fixed dependencies. Thanks!

Jindrich

Note You need to log in before you can comment on or make changes to this bug.