Bug 132420 - An installer hangs-up during reading of a package.
An installer hangs-up during reading of a package.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 03:30 EDT by Yohei Murahashi
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 11:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yohei Murahashi 2004-09-13 03:30:01 EDT
The package was read at the time of installation of Fedora for s390 
edition, the following messages were outputted to inside, and the 
installer hung-up. 


--- Copy portion ---

An unhandled exception has occurred.  This is most likely a 
 bug.  Please copy the full text of this exception and file a 
detailed 
 bug report against anaconda at  http://bugzilla.redhat.com/bugzilla

Traceback (most recent call last):   
   File "/usr/bin/anaconda", line 1162, in ? intf.run(id, dispatch, 
configFileData)
   File /usr/src/build/449901-
s390/install/  /usr/lib/anaconda/text.py", line  507, in run 
dispatch.gotoNext()   
   File "/usr/src/build/449901-
s390/install/  /usr/lib/anaconda/dispatch.py",  line 170, in gotoNext 
self.moveStep() 
   File "/usr/src/build/449901-
s390/install/usr/lib/anaconda/dispatch.py", line 238, in moveStep rc 
= apply(func,self.bindArgs(args)) 
   File"/usr/src/build/449901-
s390/install/ /usr/lib/anaconda/packages.py", line 146, in 
readPackages hdrlist = method.readHeaders()
   File "/usr/src/build/449901-
s390/install//usr/lib/anaconda/urlinstall.py", line 210, in 
readHeaders  hdr = rpm.headerLoad(hdrString) error: bad header
Comment 1 Jeremy Katz 2004-09-13 11:38:35 EDT
This is just a busted tree due to build machines not being up and
causing header lists to be bogus.
Comment 2 Yohei Murahashi 2004-09-15 03:03:10 EDT
Even if it continues installation, the system failure of the 
installation system is carried out. Isn't there any evasion method?

Note You need to log in before you can comment on or make changes to this bug.