Bug 132437 - /etc/cron.daily/makewhatis.cron: numerous lines "zcat: stdout: broken pipe"
/etc/cron.daily/makewhatis.cron: numerous lines "zcat: stdout: broken pipe"
Status: CLOSED DUPLICATE of bug 64836
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: man (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 10:30 EDT by Berthold Cogel
Modified: 2014-01-21 17:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of all rpms on a 2.1 machine experiencing problem (10.95 KB, text/plain)
2004-09-24 09:57 EDT, Eric Paris
no flags Details

  None (edit)
Description Berthold Cogel 2004-09-13 10:30:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.2)
Gecko/20040806

Description of problem:
After updating some packages on two systems cron complains about
"zcat: stdout: Broken pipe" and produces mails to root with about 6000
lines:


/etc/cron.weekly/makewhatis.cron:


zcat: stdout: Broken pipe

zcat: stdout: Broken pipe


..... 

Version-Release number of selected component (if applicable):
man-1.5k-10

How reproducible:
Always

Steps to Reproduce:
1.Wait for cron
2.
3.
    

Additional info:

See bug # 64836

If running makewhatis manually, everythig works as expected.
Comment 1 ilja lunev 2004-09-14 05:27:08 EDT
yes, I have this problem on many WS3 too.

If running makewhatis manually, everythig works as expected, but
cronjob   produce errors.

Lunev
Comment 2 Simon Karpen 2004-09-20 09:06:54 EDT
I'm also seeing the problem, on AS3 and AS 2.1. 

It started a few weeks ago, at around the same time on both platforms. 

Comment 4 Eido Inoue 2004-09-23 15:21:17 EDT
can you tell me which two packages? i can't reproduce over here.
Comment 5 ilja lunev 2004-09-24 04:52:17 EDT
for example makewhatis
Comment 6 Eric Paris 2004-09-24 09:53:28 EDT
Issue is seen on system with man-1.5k-10
Comment 7 Eric Paris 2004-09-24 09:57:09 EDT
Created attachment 104266 [details]
List of all rpms on a 2.1 machine experiencing problem
Comment 8 Eido Inoue 2004-09-24 10:00:16 EDT
Comment 7: I'm not seeing this on my up2dated AS machine (with
man-1.5k-10). I suspect that a package has been installed that has a
bogus encoding in the man page, or the system is running in a wierd
locale. I'll take a look at the rpm list and see if I can recreate it.
Comment 9 ilja lunev 2004-09-24 10:13:26 EDT
I have man-1.5k-10 on Red Hat Enterprise Linux WS release 3 (Taroon
Update 3)
Comment 10 Seth Vidal 2004-09-28 09:57:56 EDT
This is from one of the rebuild projects (centos 3.3) but it's
happening there too and it's from one of the following pkgs
kernel-smp 2.4.21-20.EL.c0.i686
kernel 2.4.21-20.EL.c0.i686
rpm-libs 4.2.3-10.i386
bind-libs 10:9.2.4-EL3_10.i386
cups 1:1.1.17-13.3.13.i386
rpm 4.2.3-10.i386
joe 2.9.8-5.i386
mod_authz_ldap 0.22-5.i386
php 4.3.2-14.ent.i386
libgcj-ssa 3.5ssa-0.20030801.48.i386
openldap 2.0.27-17.i386
libgcc 3.2.3-42.i386
tux 3.2.19-2.i386
cups-libs 1:1.1.17-13.3.13.i386
rpmdb-redhat 3.0-0.20040916.i386
libgcj 3.2.3-42.i386
vixie-cron 3.0.1-75.1.i386
XFree86-libs-data 4.3.0-68.EL.i386
rpm-python 4.2.3-10.i386
procps 2.0.17-10.i386
prelink 0.3.2-2.EL.i386
krb5-workstation 1.2.7-28.i386
laus-libs 0.1-65RHEL3.i386
ppp 2.4.1-14.1.i386
ntsysv 1.3.11-0.3.i386
httpd 2.0.46-40.ent.centos.1.i386
comps 3.0.0centos-0.20040916.i386
perl 2:5.8.0-88.7.i386
kernel-utils 1:2.4-8.37.6.i386
hwdata 0.101.12-1.noarch
kudzu 1.1.22.4-1.centos.0.i386
ypserv 2.8-7.i386
grep 2.5.1-24.1.i386
lha 1.14i-10.4.i386
sysklogd 1.4.1-12.3.i386
ethtool 1.8-3.3.i386
bind-utils 10:9.2.4-EL3_10.i386
chkconfig 1.3.11-0.3.i386
postfix 2:2.0.16-14.RHEL3.i386
dhcp 1:3.0pl2-6.14.1.i386
redhat-config-securitylevel-tui 1.2.9-2.i386
nfs-utils 1.0.6-31EL.i386
ncompress 4.2.4-38.i386
sysstat 4.0.7-4.centos.3.i386
rhpl 0.110.6-1.centos.0.i386
modutils 2.4.25-13.EL.i386
nscd 2.3.2-95.27.i386
at 3.1.8-48.ent.i386
popt 1.8.2-10.i386
MAKEDEV 3.3.12.3-1.centos.0.i386
openssl 0.9.7a-33.12.i686
schedutils 1.3.0-5.i386
libcap 1.10-15.1.i386
initscripts 7.31.16.EL-1.centos.0.i386
mdadm 1.5.0-9.i386
libstdc++ 3.2.3-42.i386
glibc-common 2.3.2-95.27.i386
nss_ldap 207-11.i386
grub 0.93-4.3.i386
fontconfig 2.2.1-13.i386
XFree86-Mesa-libGL 4.3.0-68.EL.i386
passwd 0.68-3.1.i386
xinetd 2:2.3.12-6.3E.i386
tzdata 2004b-1.EL.noarch
parted 1.6.3-29.3.i386
redhat-config-network-tui 1.2.63-1.centos.0.noarch
glibc 2.3.2-95.27.i686
readline 4.3-5.2.i386
sysreport 1.3.7.2-1.noarch
bash 2.05b-29.0.3.centos.0.i386
XFree86-libs 4.3.0-68.EL.i386
dhclient 1:3.0pl2-6.14.1.i386
krb5-libs 1.2.7-28.i386
mod_ssl 1:2.0.46-40.ent.centos.1.i386
dev 3.3.12.3-1.centos.0.i386
rdist 1:6.1.5-35.30.1.i386
shadow-utils 2:4.0.3-20.05.i386
lvm 1.0.8-5.i386
pam 0.75-58.i386
autofs 1:4.1.3-12.i386
rsync 2.5.7-5.3E.i386


That might help reduce the set to look for a broken man page somewhat.
Comment 11 Eido Inoue 2004-09-29 02:33:29 EDT
comment 10: what locale is it running in?
Comment 12 Berthold Cogel 2004-09-29 06:36:23 EDT
For our System it's LANG=de_DE.UTF-8.
Comment 13 Simon Karpen 2004-09-29 06:43:38 EDT
It's LANG=en_US on our RHEL 2.1 systems, and LANG=en_US.UTF-8 for our
RHEL 3.0 systems. 
Comment 14 Trond H. Amundsen 2004-09-29 07:01:22 EDT
Count me as one that experiences this on hundreds of boxes every week.
Some systems have 3rd-party RPMs, some have not. We use LANG=en_US for
all RHEL3 systems.
Comment 15 Seth Vidal 2004-09-29 08:00:50 EDT
Running in en_US.UTF-8
Comment 16 Seth Vidal 2004-09-29 09:57:10 EDT
I'm upgrading a system letter by letter:
yum update a\* ; makewhatis -u -w

on a system that's not been updated to u3, yet.

When I find the offending letter I'll let you know
Comment 17 Eric Paris 2004-09-29 10:48:23 EDT
I think you will find that it will always work when makewhatis is run
by hand.  If you are willing to test one letter at a time, instead
after you update a letter make sure you run makewhatis out of cron.
Comment 18 Seth Vidal 2004-09-29 10:51:46 EDT
I read the /etc/cron.daily script -it's not exactly rocket science.
Why would it fail from cron but not when run from the prompt?
Comment 19 Eric Paris 2004-09-29 11:00:30 EDT
Currently it is not known why it would work from the command line and
not from cron.  If you look at what both of the people in Comment 1
and Comment 2 said this is the case and is what we are exploring.
Comment 20 Eric Paris 2004-09-29 11:04:25 EDT
Excuse me, refer to the initial report and Comment 1,   not Comment 2.
Comment 21 Eido Inoue 2004-10-08 16:06:49 EDT

*** This bug has been marked as a duplicate of 64836 ***
Comment 22 Charlie Brady 2004-10-21 14:32:40 EDT
If you dig deep enough in history you'll see that this problem was
observed at least as far back as RH 7.3. Alan Cox surmised that it was
a problem with cron's configuration of signals when running jobs.

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64836
Comment 23 Zenon Panoussis 2005-05-04 15:31:51 EDT
Comment #18: because cron has a different environment than you have and is
probably missing something in your PATH. 
Comment 24 Red Hat Bugzilla 2006-02-21 14:05:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.