Bug 132445 - Xnest in fc3test1 segfaults when I try to use X11-forwarding
Xnest in fc3test1 segfaults when I try to use X11-forwarding
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 11:20 EDT by Njål Karevoll
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: fc3test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 18:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Njål Karevoll 2004-09-13 11:20:57 EDT
Description of problem:
Xnest in fc3test1 segfaults when I try to use X11-forwarding. No more
output is given (tried with -core, but didn't get any more output).
Xnest starts up (seemingly) without problems, but when I use ssh and
log in on the remote server, Xnest just segfaults without more
information given.

Output from Xnest:
$ Xnest :1 -core -auth /dev/null
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/,
removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/,
removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!
Segmentation fault

No special output is given from ssh.

Version-Release number of selected component (if applicable):
X Window System Version 6.7.99.903 (6.8.0 RC 3)
OpenSSH_3.9p1, OpenSSL 0.9.7a Feb 19 2003

How reproducible:
Always

Steps to Reproduce:
1. Start Xnest (Xnest :1 -auth /dev/null)
2. Try to use X11-forwarding: (DISPLAY=:1 ssh -X theserver)
  
Actual results:
Xnest segfaults

Expected results:
That Xnest stays alive and X11-forwarding works perfectly

Additional info:
Comment 1 Warren Togami 2004-09-18 23:13:23 EDT
Please test if this is still an issue with rawhide.  If so, can you
install the debuginfo package and get a gdb backtrace?
Comment 2 Njål Karevoll 2004-09-21 17:03:37 EDT
Hmm.. I can't seem to find the package (also having trouble searching
because "yum search packagename" only returns "Error: command not
implemented yet"). What is the debuginfopackage' name?
Comment 3 Mike A. Harris 2004-09-22 04:32:25 EDT
Both xorg-x11 and XFree86 packaging can't use RPM's default
strip policies, or else the X server modules get neutered.  As
such the X spec file disables rpm auto-stripping and implement's
it's own stripping.  This is why debuginfo packages are not
available for xorg-x11 or XFree86.  Implementing debuginfo would
have to be done inside the spec file stripping code, however this
is done differently in almost every version of rpm on each OS
release, so it is impractical to re-implement debuginfo code
in X packaging every time rpm changes, so no debuginfo rpms
are available.

In order to debug anything that is part of xorg-x11 or XFree86
packaging, one needs to edit the spec file, enable DebuggableBuild,
then rebuild the rpm, update to the new binary rpms, and everything
should be built with full debugging information.

Notes:
1) This results in amazingly humongous xorg-x11 rpm packages, so
   make sure you have a huge amount of disk space available, at least
   3Gb I would recommend for a full rebuild, rpm packaging, and
   upgrade.

2) Everything is debuggable with the stock "gdb" debugger except
   for the core X server "Xorg", due to the ELF loader.

This should allow debugging of Xnest however.  Hope this helps.
Comment 4 P Jones 2004-10-31 12:21:07 EST
This is still a problem with t3.  It is reproducable with package 
xorg-x11-Xnest-6.8.1-12 and just '-query'ing  localhost, so ssh is not
agravating the problem... in fact 'Xnest  :2' segs all on it's own, so
it's not in the -query code.

Note: someone should change this version to fc3test3
Comment 5 Njål Karevoll 2004-10-31 15:05:08 EST
I've been unable to debug this further, but tested it yesterday with
fc3test3 ("fresh upgrade" from fc2), which worked flawlessly. So I'm a
bit confused as to what may actually have triggered this bug, and if
it's fixed or not now..
Comment 6 Mike A. Harris 2005-03-06 18:26:04 EST
Are you invoking "ssh -Y"?  Or are you using stock default openssh
as "ssh remotehost"?

Does the problem still exist in Fedora Core 3 with all FC3 updates
applied?
Comment 7 Njål Karevoll 2005-03-06 18:52:16 EST
When I encountered the crash, it was with -X, last time I checked it
worked fine (from fc3test3 and on). So I guess its time to change the
bug status to CURRENTVERSION?
Comment 8 Michael Schoder 2005-06-25 18:33:21 EDT
Yes It appears in fc3

Note You need to log in before you can comment on or make changes to this bug.