Bug 1324454 - reboot not possible when in Emergency Shell
Summary: reboot not possible when in Emergency Shell
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-06 11:03 UTC by Oliver Haessler
Modified: 2016-11-04 08:04 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 08:04:38 UTC


Attachments (Terms of Use)
dracut emergency shell (5.32 MB, image/jpeg)
2016-04-06 11:03 UTC, Oliver Haessler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2530 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-11-03 14:17:01 UTC

Description Oliver Haessler 2016-04-06 11:03:53 UTC
Created attachment 1144191 [details]
dracut emergency shell

Description of problem:
I am using a kernel image with the "reencrypt" option to reencrypt a harddrive during first setup. The kernel does the reencrypt, and than drops into the dracut emergency shell. The only way to reboot from this shell is to press the Power button for 8 seconds to power down the notebook

Version-Release number of selected component (if applicable):
dracut-033-360.el7_2.x86_64.rpm

How reproducible:
Every time you enter the dracut Emergency shell

Steps to Reproduce:
1. enter the dracut emergency shell
2. try to reboot in different ways than powering off the notebook:
2.a type: reboot
2.b type: logout
2.c press "Ctrl-d"

Actual results:
Screen turns into plymouth screen and stays there without doing anything

Expected results:
Computer should reboot

Additional info:
It would be also great to have a grub kernel option for a auto reboot. Like in my current case.. i am using "grub2-reboot 1" to start the reencrypt kernel only once.. than i need a reboot to start the original kernel. If I could tell the reencrypt kernel to reboot automatically when entering the Emergency shell, it would make the process even easier.

Comment 2 Harald Hoyer 2016-07-22 09:55:29 UTC
reboot should work with:

http://people.redhat.com/harald/downloads/dracut/dracut-033-436.el7/

Comment 4 Michal Kovarik 2016-08-02 11:23:26 UTC
Reproduced on dracut-033-359. Verified on dracut-033-450. System rebooted without issues.

Comment 7 errata-xmlrpc 2016-11-04 08:04:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html


Note You need to log in before you can comment on or make changes to this bug.