Bug 1324461 - Listing reports for a host via API/hammer consumes large amount of memory
Summary: Listing reports for a host via API/hammer consumes large amount of memory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-06 11:21 UTC by Ivan Necas
Modified: 2020-08-13 08:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:04:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 14503 0 None None None 2016-04-26 17:11:04 UTC

Description Ivan Necas 2016-04-06 11:21:44 UTC
Description of problem:

Depending on the size of reports for a host, the request for the reports
for a host via API/hammer consumes large amount of memory.

How reproducible:
the system needs to have reasonable history of puppet reports in order to reporduce the issue

Steps to Reproduce:
1. curl -k -u admin:changeme -H "Accept:application/json"\
   https://foreman.example.com/api/v2/hosts/myhost.example.com/reports?per_page=120


Actual results:
The passenger process starts consuming a lot of memory and it takes tens of minuts to finish (if the server doesn't fail on insufficient amount of memory before it finishes).

Expected results:
The request returns reports for a host

Comment 1 Ivan Necas 2016-04-06 11:26:07 UTC
Created redmine issue http://projects.theforeman.org/issues/14503 from this bug

Comment 3 Ivan Necas 2016-04-06 11:34:16 UTC
A PR with a fix proposal opened upstream https://github.com/theforeman/foreman/pull/3394

Comment 4 Bryan Kearney 2016-04-06 12:03:55 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2016-04-07 08:03:49 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14503 has been closed
-------------
Ivan Necas
Applied in changeset commit:aeba4f428494f2ee3aedf18088561c23c4407309.

Comment 6 jcallaha 2016-05-27 15:40:45 UTC
Verified in Satellite 6.2 Beta Snap 13.

It only took 1120ms to return a list of 345 reports, when overriding the default pagination limits.

Comment 7 Bryan Kearney 2016-07-27 11:04:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.